Cameras

Question

Canon Rebel t3i Screen issues, need help

by samzabar / March 5, 2013 8:01 AM PST

Hey. So I recently bought a Canon Rebel T3i and I am having an usual problem with my screen. Whenever I turn my camera OFF after using it for any period of time the screen gets all screwy. I get these crazy purple and green vertical lines, and they don't go away until I take my battery out. This camera is brand new and it is already doing this to me. I am concerned that the camera is still on after I turn it off, it's strange.I went to best buy and they said it's gonna be an $85 charge to get it sent out to the manufacturer and I don't want to spend that because it would be a free fix with the 1-year warranty I have on the camera. I need advice if there is anyway to fix it on my own, if not I'll ship it out to the manufacturer on my own, not threw crappy best buy.

Thanks!

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Canon Rebel t3i Screen issues, need help
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Canon Rebel t3i Screen issues, need help
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Have that model. Never seen that issue.
by R. Proffitt Forum moderator / March 5, 2013 8:06 AM PST

If you are using Best Buy to handle in warranty work, the charge seems right as they are packing, shipping and doing the handling so not much wrong with that.

Most of these cameras are not repaired by the owner.
Bob

Collapse -
Answer
Reset
by snapshot2 Forum moderator / March 5, 2013 10:46 AM PST

It is possible you may have inadvertently set something that is causing the problem.
Before you send it off I suggest you do a factory reset.
See page 176 in the manual.

If that does not help, you should call Canon Service and talk to them.

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech for the holiday

Find recipes for July 4 with these foodie apps

The Fourth of July means fireworks, fun and food. If you're planning on a barbecue this weekend, we've got the apps to help you find holiday-inspired recipes.