Networking & Wireless forum


Can't renew IP address

by spartax81 / October 9, 2012 9:07 AM PDT

Hi, I'm new here and not too network-savvy. I'm trying to go wireless with a desktop PC running Windows XP SP2. I've got a 2WIRE router which works fine when plugged into the computer via an ethernet cable. I purchased a Netgear N300 Wireless USB adapter and installed it - it seems to be working fine.

The trouble is that my wireless connection shows "limited or no connectivity," although the signal strength is "very good." When I try to repair the connection, it tells me that I could not be assigned an IP address.

At the moment I'm working via the Ethernet cable with no difficulty. Can someone suggest a reason why the wired connection works but the wireless (from the same router) doesn't, even though it should?

Thanks in advance for any help!

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Can't renew IP address
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can't renew IP address
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Too many causes.
by R. Proffitt Forum moderator / October 9, 2012 9:18 AM PDT
In reply to: Can't renew IP address

It could be that the OS is out of date (SP3 has been out for years and many drivers expect it.)

You never revealed if it ever worked. I now that setup can be horrible and today's users are not ready for this old thing.

Tell more. Such as if you tried it within 10 feet of the un-named and untold settings router. For example I do not expect it to work if the SSID is hidden. I also expect this to fail if the ethernet is plugged in, if the Ethernet IP settings were set manually and if the IP addresses are still around when you try the WiFi.

Lots to consider. Lots of things today's owners have reason to move away from this old thing.

Collapse -
first clarification
by spartax81 / October 9, 2012 9:28 AM PDT
In reply to: Too many causes.

Router and adapter are in the same room, about 6 feet apart. Router has always worked previously, just using ethernet cable. But I've never tried it wirelessly before. SSID broadcast is enabled. Router is a 2WIRE 2701HB-G.

If I understand you, you're saying that you don't expect the wireless adapter to work if my ethernet cable is also plugged in?

Collapse -
That's right.
by R. Proffitt Forum moderator / October 10, 2012 2:40 AM PDT
In reply to: first clarification

If the ethernet is plugged in the IP assigned there is on the same LAN as what the WiFi will try to get assigned.

So if you recall your basic network classes you can't have 2 interfaces on the same LAN (well, without a lot of work.)

Collapse -
by spartax81 / October 11, 2012 6:04 AM PDT
In reply to: That's right.

But I eventually had to take it to an IT pro for some other issues, so I'm having the network issue addressed at the same time. I appreciate your help.

Collapse -
Check some settings
by 007networkpro / November 1, 2012 6:50 AM PDT
In reply to: Can't renew IP address

If your wired connection works fine but not your wireless then you can eliminate your modem and you wired LAN settings. I would take a look at my wireless LAN settings, make sure it's set to DHCP and check out what range you have it set to. If you get that message see if you can ping your default gateway.

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions


Having Wi-Fi troubles?

From the garage to the basement, we blanketed every square inch of the CNET Smart Home with fast, reliable Wi-Fi.