Windows Legacy OS forum

General discussion

Can't open "My Pictures" folder properly.

by chgo29 / December 6, 2006 11:43 AM PST

I've been running XP Home for years now and this is the first time this has happened to me. When I double click on the "My Pictures" desktop shortcut - or on the "My Pictures" folder in "My Documents", I get a "Search" window instead of all my picture folders and icons. I can still get to my picture folders and icons by right clicking on the shortcut and choosing "Open". But I would like to fix this. When I right click on the shortcut, and the shortcut menu comes up, SEARCH is highlighted and is at the top of the menu, so it is the default action for this shortcut. All my other shortcuts have OPEN highlighted, at the top of the menu, and it is the default action. How "My Pictures" default got changed I don't know and I can't figure out to change it back to OPEN. I've tried deleteing the shortcut and making a new one but that doesn't help. I even get "Search" if I click on the folder icon in "My Documents". Help !! Cliff

Post a reply
Discussion is locked
You are posting a reply to: Can't open "My Pictures" folder properly.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can't open "My Pictures" folder properly.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: Can't open "My Pictures" folder properly.
by Tufenuf / December 6, 2006 12:02 PM PST

Go to Start/Run and type in: regsvr32 /i shell32

If that doesn't correct the issue which it should, use this automated edit:

Search Opens When Double Clicking a Folder or Drive (Line 18-right column).

Save the REG File to your hard disk. Double click it and answer yes to the import prompt.


Collapse -
Tks Tufenuf! Had the same thing in the last 4 days WINXP H E
by DarCLew2 / December 6, 2006 1:13 PM PST

I thought I had something that caused it but "Go to Start/Run and type in: regsvr32 /i shell32" did the fix, Home Edition 2002 also. Darrell L.

Collapse -
Thanks Tufenuf - chg'd default by opening Folder Options
by chgo29 / December 7, 2006 1:13 AM PST

I never have messed with Registry so I thought I'd try "Restore" before I did your regsvr32/i shell32 thing - and restore fixed it. But, as a note of interest - I had posted the same question on the PCMech forum and the admin. linked me to a Microsoft support article 25986 ( that says you can inadvertently change the default just by opening up "Folder Options" and going thru a few more steps, even though you don't change or edit anything. A fault of Windows XP. And I had done just that, cause I had read an article by Jim Coates - Chicago Tribune Computer guru - about going into Folder Options to change your folder icons. And I went there just to look at it. So, thanks for your response. Cliff

Collapse -
My pictures snafua
by gelian / June 16, 2009 4:29 AM PDT

I had a different sort of problem. I could open My Pictures but 90% of the photos in a folder were not visible. I tried your advice and it worked like a charm


Heres a new problem
When I download a video from some internet sites they automatically go to a full screen mode and then I cant escape no matter what keys I try.
I have to shut down the PC directly from the PC tower and then restart as I cant find any commands since I am the full screen mode

Any advice?

Thanks again

Collapse -
Video problem
by MarkFlax Forum moderator / June 16, 2009 5:44 AM PDT
In reply to: My pictures snafua

Not really anything to do with this discussion, and posting to 'old' threads like this often means that the regular helpers here 'walk on by' when the see the age of the first post. You would have done better creating your own new discussion.

I'm not sure of your problem. There are two ways of viewing videos from web pages.

1] Streaming video. You don't 'download' the video file yourself. Instead the web page 'streams' the video direct to a video player plugin installed in your browser. Once the video is finished, your computer does not retain the video file. With this method, the video size is fixed by the dimensions set by the web page designer and is usually much smaller than the browser page itself. However, right clicking inside the video window will sometimes offer options to expand to full screen. Some of these in-page video players also have a full-screen button.

To exit from the full-screen in these cases, you either press the ESC key, or click the 'return to normal size' button, or perhaps right click and make a choice on the menu.

2] Downloaded files. If a web site offers a file download, you would normally select to "Save to file", instead of running the file. This is so you can scan the file for viruses before opening it.

Once scanned and assuming the file is malware free, then you can double click the file and watch it in the media player. But different file types will use different media players, for example, RM files will play in Real Player, and WMP files will normally play in Windows Media Player. However, users can change these file associations themselves to choose different media players as their default players.

Without knowing more about what you do, where the files come from, and what media players are used, I am not sure what advice can be given. Have you tried right clicking the full-screen window and selecting "Video size", or similar?


Collapse -
Full screen
by gelian / June 16, 2009 7:39 AM PDT
In reply to: Video problem

thanks for the info Mark

I am not sure of the path of some of these videos playbacks so I will check in the future - I don't recall being given an option of how to watch the video PS I use latest version of Adobe flash


Collapse -
getting search when trying to open a folder
by nanc_1 / September 1, 2010 5:44 AM PDT

Thank you so much I have been pulling my hair out trying to solve this problem. I have looked at several on line help but nothing worked. Your solation was so fast and simple and it worked.

Thank you again

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions


Free trip to the Grand Prix

Don't miss your chance to win a trip to the Formula 1 Grand Prix in Monaco for you and a plus-one.