Browsers, E-mail, & Web Apps

General discussion

Can't Enable Java on my Windows Explorer Browser

by gloria2010 / July 4, 2008 4:19 AM PDT

I can't seem to be able to enable Java on my browser.
At one point, my Browser was hanging up so I made the mistake of going to the 'Advanced' tab on my Internet Options dialog and selecting the 'Reset...' button.
After that I could not view lectures of a class I am taking because the error: 'Your browser is NOT JavaEnabled...'.
I went to the Java website and downloaded and installed the JRE software so that on the 'Security' tab selections of:
Scripting of Java applets is enabled.
Advanced Tab
Java(Sun) - Use JRE 1.6.10... is checked.
Microsoft VM
JIT compiler for virtual machine is enabled.

I restarted the Internet Explorer and restarted my computer to no avail...when I try to view lectures I get the same error:
Browser is NOT JavaEnabled...

Is there ANY way to fix this? Is there another way to view the lectures? Is there another browser I can download to view the lectures?
Any help would be greatly appreciated!
Thanks,
Gloria

Discussion is locked
You are posting a reply to: Can't Enable Java on my Windows Explorer Browser
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can't Enable Java on my Windows Explorer Browser
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
A quick fix
by MarkFlax Forum moderator / July 4, 2008 4:50 AM PDT

Hi Gloria.

A quick fix to get you working again is to download another type of browser. One of the most popular is Firefox 3 from Mozilla, at http://www.mozilla.com/en-US/

It doesn't replace IE, but is just an additional browser. In fact you could, if you wished, have both browser open at the same time with no problems.

I'm not sure what this content is you are trying to view, but Firefox also accepts Java. However you may have to revisit the Sun Java website to download the Java plugin whilst using Firefox.

You don't need any of the Microsoft VM Java options selected. Microsoft's Virtual Machine is now obsolete. (IE Tools > Internet Options > Advanced).

Also, in the Security tab, with the IE globe highlighted and in Custom levels, have you enabled Java VM > Java permissions? Scripting of Java applets is near the bottom of that list, but Java VM is more towards the middle.

I hope that helps.

Mark

Collapse -
Mozilla downloaded and still have problems
by gloria2010 / July 9, 2008 12:44 PM PDT
In reply to: A quick fix

I downloaded and installed Mozilla Firefox 3.
I made sure Java was Enabled and tried viewing my lectures.
When I double-click on the video executable I get the Mozilla browser with an error message:
Quick Time Player (version 6.0 at least) is required to view the class.

I downloaded and installed Quick Time Player 7 from the Apple website. I have run the repair program twice and still get this error.

Any suggestions?

Thanks,
Gloria

Collapse -
Hmmm.
by MarkFlax Forum moderator / July 9, 2008 7:52 PM PDT

Frankly I'm stumped Gloria. That QuickTime message is confusing as it was not mentioned in your first post. I suspect because IE did not mention it. QuickTime is a movie player and I am not sure why it is needed to view lectures.

I don't suppose anyone else, (like me), can go to this web site and see if we can access your lectures? If it is password controlled or any other type of secure site, (where the web address starts with https and not http), then we cannot, and I would not ask you for details how to access the site.

Just to make sure I get you right, did you make that change to IE's Security levels?

Let's see if you can test both your browsers for Java and QuickTime. There are a number of Java Tester web sites in Google, (Java test site), and one is here;
http://www.javatester.org/

See how you get on with that.

For Firefox there is a specific QuickTime tester site here;
http://www.mozilla.org/quality/browser/front-end/testcases/plugins/quicktimetest.html

Whilst for IE, I would go to Apple's own QuickTime test site here;
http://www.apple.com/quicktime/troubleshooting/

Let us know how you get on.

Mark

Collapse -
Quick time error
by gloria2010 / July 9, 2008 10:48 PM PDT
In reply to: Hmmm.

Sorry...I was not clear.
The Quick Time error appears when I use the Firefox Mozilla browser, not the Windows Internet Explorer.

The options to enable Java that I am aware of in the IE browser I have set as follows:

Security Tab
Microsoft VM - set to Medium safety
Scripting - scripting of Java applets - Enabled
Advanced Tab
Java(Sun) - Use JRE 1.6.0_10 for <applet> - Enabled
Microsoft VM - Java console - Enabled
Java logging - Enabled
JIT compiler for virtual machine - Enabled

The options I have set for Mozilla for Java that I am aware of are as follows:
Under Tools / Options / Content
Load images automatically - Checked
Enable JavaScript - Checked
Enable Java - Checked

I downloaded the lectures from the secure website and the ones I am using to test are on my laptop.
The lectures are videos of professors from a previous class so I can see why Mozilla needs the Quick Time software but I installed it and I still get the error.

Thanks,
Gloria

Collapse -
Java tester
by gloria2010 / July 9, 2008 10:54 PM PDT
In reply to: Hmmm.

Another comment...
I used the website you provided to test the Java in Mozilla and IE browsers.
Mozilla browser has Java working
IE browser does not have Java working.

I will go to the website for Mozilla you suggest...I have given up on getting IE to work, and see if that will help.

Thanks for your help and quick responses!
Gloria

Collapse -
Quick Time test
by gloria2010 / July 9, 2008 11:20 PM PDT
In reply to: Hmmm.

I went to the website to test the Quick Time plugin.
Of the seven tests, I could see 5 of the videos. Test #2 and #4 did not show the video.

The lectures are typically 1 - 1.5 hours. Would that be a problem?

Gloria

Collapse -
That's interesting, but I wonder....
by MarkFlax Forum moderator / July 10, 2008 2:28 AM PDT
In reply to: Quick Time test

Yes I must admit I hadn't tested them all myself but my Firefox browser, (Mozilla), also failed tests 2 and 4. I believe there is little we can do about that because it depends how the web site is coded.

But I wonder. When I loaded that web site in FF my Zonealarm firewall popped up a message warning me that Firefox was trying to act as a server. Whilst FF has automatic access to the internet it does not, on my system, have authority to act as a server itself and so ZoneAlarm asks me for permission.

Whilst you do not seem to have a problem with FF acting as a server, (you may not have seen any videos if you had), I wonder if this problem is a firewall issue on your computer.

Do you have a firewall installed on your computer? If so, which one? it may be that either of the browser types have different permissions in the firewall settings.

Mark

Collapse -
Firewall
by gloria2010 / July 10, 2008 2:54 AM PDT

I'm embarrassed to say, I don't know if I have a firewall installed on my computer.
I have Symantec Antivirus running and looking through the Control Panel options, I see a Windows Firewall set to the 'Recommended' setting. That is it.

Collapse -
Yes it will be the WIndows Firewall.
by MarkFlax Forum moderator / July 10, 2008 7:18 PM PDT
In reply to: Firewall

But in that case I doubt the Windows Firewall is causing this problem.

Frankly, I am running out of ideas now. Am I right in thinking that you used to be able see these lectures in Internet Explorer in the past? If so, what has changed on that computer since then? Have you installed any software, Windows Updates, or uninstalled anything?

If it was working but now isn't, then something has changed to stop it working.

Mark

Collapse -
Yes...Reset my Internet Options
by gloria2010 / July 10, 2008 10:26 PM PDT

At one point, my IE Browser was hanging up so I made the mistake of going to the 'Advanced' tab on my Internet Options dialog and selecting the 'Reset...' button.

After that, my nightmare began...
I tried to view my lectures and I got the error Java is not Enabled.
I went to the Sun website and downloaded and installed the JRE.
Got all of the options set, still the same error.

Collapse -
Try This
by Tufenuf / July 10, 2008 11:10 PM PDT

Gloria, Posted:

The options to enable Java that I am aware of in the IE browser I have set as follows:

Security Tab
Microsoft VM - set to Medium safety
Scripting - scripting of Java applets - Enabled
Advanced Tab
Java(Sun) - Use JRE 1.6.0_10 for <applet> - Enabled
Microsoft VM - Java console - Enabled
Java logging - Enabled
JIT compiler for virtual machine - Enabled

Under the Security tab also under "Scripting" make sure that "Active Scripting" is Enabled.


Try changing your settings under the IE advanced tab the 3 entries under Microsoft VM to Disabled (not checkmarked) instead of Enabled (checkmarked).

What may be causing the problem is that you have the Java(Sun) and the Microsoft Virtual Machine both enabled and only one or the other should be enabled NOT both.

Here's another Java Test link.
http://www.bodo.com/javame.htm

Tufenuf

Collapse -
Still does not work...giving up
by gloria2010 / July 11, 2008 12:23 AM PDT
In reply to: Try This

To All Who Have Helped,

Still giving the error.
Disabled the JIT. Restarted IE...still get the Java not enabled error.
Tried restarting the computer...still got the error.

I tried the website with the Java test and it says that Java is not installed. Tried going to the website to download and web page could not be found.
I have downloaded the VM several times before. Uninstalled and reinstall to no avail.

Thanks for your help...I don't think there are any other paths to take.

Gloria

Collapse -
Don't give up
by Tufenuf / July 11, 2008 12:36 AM PDT

Gloria, Don't give up. Go into your Control Panel and open the Add/Remove Programs applet and let us know which Java programs are installed?

Tufenuf

Collapse -
OK..but tell me when you had enough :)
by gloria2010 / July 11, 2008 12:55 AM PDT
In reply to: Don't give up

The programs are as follows:

J2SE Runtime Environment 5.0 Update 5
J2SE Runtime Environment 5.0 Update 6
Java DB 10.2.2.0
Java (TM) 6 Update 10
Java (TM) 6 Update 2
Java (TM) 6 Update 6
Java (TM) SE Development Kit 6 Update 2

Collapse -
Gloria, Here's what I'd do.
by Tufenuf / July 11, 2008 1:41 AM PDT

Gloria, I'm assuming that you're using Windows XP. If that's correct what I'd try is to go to the link below and download the "Windows XP/Vista/2000/2003 Offline" file and save it to your desktop. After tou do that go into your Add/Remove Programs and uninstall all of those Java entries you posted one at a time. I'd then restart your computer then go to your desktop and double click that Java file you downloaded and follow the instructions and install it.

Here's the download link and you want the "Windows XP/Vista/2000/2003 Offline" file which is 15.18 MB in size. You can read the "instructions" first.

http://www.java.com/en/download/manual.jsp

Tufenuf

Collapse -
No change
by gloria2010 / July 11, 2008 2:58 AM PDT

I did what you wrote.

Download JRE
Uninstall all of Java.
Restart computer
Install JRE.
The Java programs I have now is: Java(TM)6 Update 7

In the Add/Remove Programs, there is a program, Diagnostic Tool for Microsoft VM.

I must have downloaded it at some point.

I am running it now to see if it tells me anything.

Thanks for everything.
Gloria

Collapse -
Re: No change
by Tufenuf / July 11, 2008 3:07 AM PDT
In reply to: No change

Gloria,

To see whether your browser is configured to use the Java Runtime Environment (JRE) or not, first open the Windows Control Panel. From the Start menu button, select Settings, then Control Panel to open the Control Panel. You should see the Java Coffee Cup logo icon in the Control Panel.

Double-click the icon to open the Java Control Panel.
In the Java Control Panel, click the Advanced tab.
Under Settings, click on + icon against <Applet> tag support.
Make sure the box next to Internet Explorer, Netscape, or Mozilla is checked.
If it is not checked, click the checkbox to enable the JRE for your Web browser.
Click Apply.

Also go back into Internet Options>Advanced tab and make sure that Java (Sun)>Use Java is checkmarked and everything under Microsoft VM is unchecked and restart your computer.

Hang in there.

Tufenuf

Collapse -
Missing applet tag
by gloria2010 / July 11, 2008 3:24 AM PDT
In reply to: Re: No change

In the Java Control Panel on the Advanced Tab
under Settings, I don't have an '<Applet> tag support' option.
I have the following:
Debugging
Java console
default Java for browsers
Shortcut Creation
JNLP File/MIME Association
JRE Auto-Download
Security
Miscellaneous

Within these options there is no <Applet> support option.
Only reference to applets is under Debugging...Show applet lifecycle exceptions

I'll keep trying as long as you have ideas.

Gloria

Collapse -
Re: Missing applet tag
by Tufenuf / July 11, 2008 3:45 AM PDT
In reply to: Missing applet tag

Gloria,

To see whether your browser is configured to use the Java Runtime Environment (JRE) or not, first open the Windows Control Panel. From the Start menu button, select Settings, then Control Panel to open the Control Panel. You should see the Java Coffee Cup logo icon in the Control Panel.

Double-click the icon to open the Java Control Panel.
In the Java Control Panel, click the Advanced tab.
Click on + icon next to Default Java for browsers.
Make sure the box next to Internet Explorer, Netscape, or Mozilla is checked.
If it is not checked, click the checkbox to enable the JRE for your Web browser.
Click Apply.

I don't know how that word "<Applet>" showed up in my previous reply but try the instructions above again.

Click on + icon next to Default Java for browsers.
Make sure the box next to Internet Explorer, Netscape, or Mozilla is checked.

Checkmark the box for the Browser you're using.

I'll hang in here for a while yet and we'll hopefully get this problem corrected.

Tufenuf

Collapse -
Applet Tag
by gloria2010 / July 11, 2008 7:17 AM PDT
In reply to: Re: Missing applet tag

When I checked the default browser, both the IE and Mozilla were checked.
I unchecked Mozilla and restarted the browser to see it that makes a difference and it did not.

Collapse -
Re: Try this
by Tufenuf / July 11, 2008 7:54 AM PDT
In reply to: Applet Tag

Gloria, Which version of Internet Explorer are you using? Just for the heck of it go into Internet Options>Advanced tab and uncheck anything under Java (Sun) and then under Microsoft VM checkmark "JIT compiler for virtual machine enabled (requires restart)" and restart your computer. Now see if Java is working on those sites. This indeed is a strange problem.

Tufenuf

Collapse -
More info
by Tufenuf / July 11, 2008 8:15 AM PDT
In reply to: Applet Tag

Gloria, If you're using IE 7 check out the link below under "Internet Explorer 7". If applicable make sure you choose Enable and NOT Disable.

http://kb.iu.edu/data/ahqx.html

Tufenuf

Collapse -
They were enabled
by gloria2010 / July 11, 2008 9:11 AM PDT
In reply to: More info

The Java Plug-in was enabled and so was the scripting in the Security Tab

Collapse -
Re: They were enabled
by Tufenuf / July 11, 2008 10:01 AM PDT
In reply to: They were enabled
Collapse -
IE Version
by gloria2010 / July 11, 2008 12:54 PM PDT
In reply to: Re: They were enabled

I am using IE Version 7.
I went to the website that you suggested and followed the instructions.
The options were already enabled so there was nothing for me to do.
Did I misunderstand you?

Collapse -
Re: IE Version
by Tufenuf / July 11, 2008 1:02 PM PDT
In reply to: IE Version

Gloria, Just for the heck of it go into Internet Options>Advanced tab and uncheck anything under Java (Sun) and then under Microsoft VM checkmark "JIT compiler for virtual machine enabled (requires restart)" and restart your computer. Now see if Java is working on those sites. This is a weird problem indeed.

Tufenuf

Collapse -
cannot enable java on w7
by PJRiter / November 9, 2012 4:26 AM PST

I just fixed this problem for win 7. You have to download the jre save to directory c:java and install as administrator (right click and choose 'run as administrator'. then go to the control panel and edit the path under system to make sure the first item is c:/java so that your app can find the new good jre (use the path to where you chose to put it). Then it worked. I think i hade to delete another path to a java quick time so it did not get confused. The problems are win 7 needs you to choose run as admin to install something even if your id is an admin and the path environment variable must have only one path to the new good java and no paths to other bad jre so the app uses the right one,. must reboot and maybe clean cache after install. Very exhausting hours to find sol.

Collapse -
Exhausting is the right word.
by R. Proffitt Forum moderator / November 9, 2012 4:30 AM PST
Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech for the holiday

Find recipes for July 4 with these foodie apps

The Fourth of July means fireworks, fun and food. If you're planning on a barbecue this weekend, we've got the apps to help you find holiday-inspired recipes.