Windows Legacy OS forum

General discussion

Can't adjust resolution above 640x480 4bit

by Steady65 / December 24, 2007 1:34 PM PST

OS: WinXP SP2 with all updates
Video card: Gforce FX 5200
Monitor Envision 775e

First off, I totally believe this is an OS problem based on the troubleshooting I've done, if the mods feel this would be better in another forum please move it. Thank you.

O.K. This is probably going to sound like an easy one, but it's got me stumped. Up until yesterday everything worked fine, until I unplugged my monitor in order to test another machine, when I plugged it back into my main machine I only had 640x480 graphics (this was at the login screen.)

When I logged in and went to video settings the only options I had were 640x480 and 800x600, but couldn't move the slider to 800x600. The only color quality available was 4 bit. I removed the display adaptor from device manager along with the monitor. On reboot everything looked normal (I had all resolution options available in settings), windows detected a vga controller, but not my actual card. I then installed my video card drivers, on reboot I was back to 640x480.

I removed the display adaptor and rebooted, it returned to a normal screen. I loaded older drivers and I went back to 640x480.

I booted to safe mode (with the fx5200 drivers still installed) and everything was normal, device manager says it's using fx5200 drivers. Display settings says it's default monitor on FX 5200 (I'm pretty sure I've always just used default monitor, but I found and loaded the envision drivers and got the same results). I don't have any options for refresh settings other that 60hz with either the default monitor loaded or the envision.

I then removed display adaptor, and clean booted, all looked normal but again only detected vga compatible card, loaded drivers and back to 640x480.

I turned off all services except those that were running in safe mode and tested again. Same results.

removed display adaptor, booted to safe mode and loaded drivers in safe mode. On reboot I was still at 640x480.

At this point I'm thinking maybe my card fried (but it works in safe mode), so I put in an older gforce 2 gts. Windows loaded but only found a vga compatible card, not my actual card (resolution was fine). Loaded the GTS drivers and I went back to 640x480.

I then put both cards into another winxp machine (different harddrive), windows detected each of them for what they were (the FX5200 or GTS) and loaded drivers automaticly. I then pulled the harddrive from the machine that wasn't working and tried it in another machine (thinking it might be a MB are AGP slot problem. As soon as I booted up, it again only detected a VGA compatible card (normal resolution) and as soon as I loaded drivers I went to 640x480.

There may have been some other steps in here that I tried but I don't remember them as I've been through this many times.

So at this point, I'm totally stumped. Anybody have any ideas. I'm not ready to reinstall OS yet, but getting close.

Thanks in advance.

Post a reply
Discussion is locked
You are posting a reply to: Can't adjust resolution above 640x480 4bit
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can't adjust resolution above 640x480 4bit
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
have you tried the display troubleshooter?
by jonah jones / December 24, 2007 10:24 PM PST

desktop
properties
settings
troubleshooter

also try the 'advanced' button


jonah

.,

Collapse -
already tried
by Steady65 / December 25, 2007 3:09 AM PST

Jonah

I already tried the troubleshooters, they really aren't much help. They just have you update drivers and change monitor (already done), update bios (not a bios issue as it happens with same harddrive on a different motherboard AND it has worked fine for over a year with same bios), and check compatability list (both cards are compatible).

I've also already been through the advanced section. When I have the drivers loaded it only lists 640x480 and 800x600 as available modes. When I leave it as a VGA compatable device I have all modes up to 2048x1536 available. Monitor settings only allow me to use default refresh rate for "default monitor" or 60hz if the Envision is loaded.

I really believe something is not allowing the drivers to load properly as they work fine in safe mode, but I just can't figure out what.

Collapse -
Video drivers = Check!
by R. Proffitt Forum moderator / December 25, 2007 3:16 AM PST

Motherboard drivers? Hmm, no mention yet.

Collapse -
no change
by Steady65 / December 25, 2007 4:25 AM PST
In reply to: Video drivers = Check!

Just installed latest via 4n1 drivers. No change.

Collapse -
Since it worked just a little while ago...
by R. Proffitt Forum moderator / December 25, 2007 4:27 AM PST
In reply to: no change

Use SYSTEM RESTORE to that date.

Collapse -
wish I could
by Steady65 / December 25, 2007 4:55 AM PST

Mmmmm yea, wish I could do that. I had turned off sys restore not too long ago to get rid of virus in restore point. Unfortunately I didn't turn it back on. Wish I had that one back Happy

Collapse -
I just fixed one like that.
by R. Proffitt Forum moderator / December 25, 2007 6:42 AM PST
In reply to: wish I could

The motherboard drivers usually do the trick. Now off to google.com and type in XP REPAIR INSTALL.

Sorry if this doesn't apply to your version of XP. There are some missing details in your post.

Bob

Collapse -
re-install time
by Steady65 / December 26, 2007 12:57 AM PST

Well, I'm tired of playing with it. I'm going to try a repair install and if that doesn't work, back up the important stuff and go from scratch.

Thanks all.

Collapse -
Possible fix
by wizardaj83 / February 13, 2008 1:55 PM PST

This is probably too late but I had the same problem with my GeForce 6200 and fixed it by going into Control Panel>Display Properties> Settings>Advanced>Troubleshooting and once I turned my hardware acceleration all the way down I was able to change back into 32 bit 1024x786. I turned the hardware acceleration back up and it is still working fine.

Collapse -
The solution is hidden here
by Dango517 / February 13, 2008 2:31 PM PST

My comments in [brackets]

"At this point I'm thinking maybe my card fried (but it works in safe mode), so I put in an older gforce 2 gts. Windows loaded but only found a vga compatible card, not my actual card (resolution was fine). Loaded the GTS drivers and I went back to 640x480.

I then put both cards [BOTH? The SLI feature is required to run more then one GPU at a time. Try just using one card at a time.] into another winxp machine (different harddrive), windows detected each of them for what they were (the FX5200 or GTS) and loaded drivers automaticly.[ Did they work here, at this point when the drivers were installed automatically?] I then pulled the harddrive from the machine that wasn't working and tried it in another machine (thinking it might be a MB are AGP slot problem. As soon as I booted up, it again only detected a VGA compatible card (normal resolution) and as soon as I loaded drivers I went to 640x480."

More about SLI:

http://en.wikipedia.org/wiki/Scalable_Link_Interface

Hope this helps. Happy

Collapse -
Did you note this
by Dango517 / February 13, 2008 2:38 PM PST

"NVIDIA's Forceware drivers 80.XX or later" in the SLI text on Wikipedia?

Collapse -
It's solved.
by Steady65 / February 14, 2008 1:03 AM PST
In reply to: Did you note this

This has been solved awhile. It was actually the monitor that was the problem. I put a different monitor on and everything worked fine. Thanks to those that posted suggestions. And just to clear something up. When I said "I put both cards in another machine", I didn't mean at the same time LOL. I should have said "I tested both cards in another machine (but same monitor, hence the reason the problem continued, I know this now as an afterthought LOL).

Anyways thanks again.

Collapse -
Great!
by Dango517 / February 14, 2008 4:15 AM PST
In reply to: It's solved.

Glad it's working again. I learned something more about SLI so my time wasn't wasted. Good luck.

Collapse -
My Solution
by McHotpants / July 16, 2010 4:22 AM PDT

Hey, I recently came across this same issue on my Evga Nvidia 6200 AGP which gave me, Code 12, 640x480 4 bit color, conflicting with VGASave and all that other BS. I placed in a call into Nvidia and after an hour or so they tell me to RMA It. I knew this wasn't going to be an option since I didn't want to wait.

So I start playing with bios settings. Everyone is saying its the onboard video, My bios doesn't allow me to disable it. Which is due to the fact it's supposed to auto disable in a VGA device is detected. Well anyways, straight to my SOLUTION, I had my AGP aperture size set to 256, and I was thinking this is a 512 card, but it won't let me raise it up to 512... WTF... So I then come across this page stating...

"AGP Aperture memory will not be used until your video card's on-board memory is running low. That means it will usually not impact your gaming performance because developers are trying hard to not exceed the on-board memory limits.
The bigger your video memory, the smaller your Aperture Size could be. However with later games requiring more and more texture memory a good number seems to be 128MB Aperture Size for all cards with 64 MB to 256 MB Video RAM.
Setting the Aperture Size to HUGE values will not increase performance because this merely sets the maximum amount of physical memory that can be used. It only makes the GART Table bigger because every 4K page has its own entry, no matter if allocated or not.
Setting the Aperture Size to too small values could result in running out of available texture memory especially on a low-mem video card. It is also possible that developers make use of the GART's features by creating textures as 'non-local'.

If you experience in-game stuttering try playing with the size of your Aperture."

http://www.techpowerup.com/articles/overclocking/vidcard/43

So I lower my AGP aperture size (in your Bios which is usually accessed by pressing the F2 or Delete button at your Motherboards info screen at the very start of the boot sequence.) to 128 and viola! So if you have this issue try lowering your aperture size and see if that helps. Not sure if it will be your solution, but I haven't seen anyone past this from all the threads I went through. A pain in the butt, but better than an RMA. I also called up Nvidia and told them they should consider adding that to their trouble shooting documents they read from since most of them just read and don't know what they are talking about. Anyways, hopefully this will help someone. Even if it's just 1 person, I know I would have liked to of seen all the solutions available.

Collapse -
You are awesome!!!
by bombscarejr / November 14, 2012 3:10 PM PST
In reply to: My Solution

I looked and looked, and spent days and finally the person with the answer to my problem. I brought my AGP aperture size down to either 4 or 8 mb from I think 64 running a Frankenstein pc i put together. It was stuck in 640x480 4-bit and now it's 1152x864 32 bit. So many options had been unusable dpi, Direct3D Acceleration. My Powercolor 3850 AGP is ready to go again! Thank you, thank you, thank you - I could hug you. But that would be weird. You are so right that this answer should be more available or out there. Thanks for posting it.

Collapse -
Additional details to help
by bombscarejr / November 15, 2012 1:01 AM PST
In reply to: You are awesome!!!

I'd spent months at it since it's not a primary computer. & some very late nights. This PC worked very well playing SW Republic Commando in early 2010. After a hiatus, I tried to use it in Feb 2011 on an lcd monitor - no luck. 640x480, 4 bit. and it would be stuck there. I would reinstall the drivers and found that an older 8501agpXP would pull it out of the stuck resolution. I would use "Can YOu run it" to get an idea if i could run a certain game & it came back that I had zero video ram. I'm supposed to have 512mb. Used CPUID, it would tell me just the specs - that my card has 512mb. Used dxdiag.exe, that would say 3D acceleration unavailable and AGP texture acceleration unavailble. SInce the card worked - showing some type of screen - from what I read I thought it was a driver issue. Driver after driver, uninstalling, re-installing rolling back, updating - tried them all. Even switched out the motherboard because I had an unused LGA 478 P4 2.66 - still no fix. Ran thru windows support/ MS 8 or 9 methods of solving video issues. Backed up everything and did a clean swipe - re-installing just the essentials. Looked & looked. Still nothing. Finally AGP texture size. Went form bios default of 64 to 4mb. I unplugged the PC afterwards last night then plugged it in again this morning. It showed up again 640x480, 4 bit. Again I just adjusted AGP texture size in BIOS and it was good to go. Thanks again.

I'm using a P4 Northwood 2.66, 2gb RAM, XP Pro SP3, 650 psu, PowerColor 3850AGP 512mb Copper cooler.

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Smartphone tip

Hoarding photos on your phone?

Those picture are hogging memory and could be slowing down your phone.