If you are using IE, (6 or 7), I would first of all check that its Advanced settings show SSL 3.0 and TLS 1.0 are selected. (Tools > Internet Options > Advanced tab, scroll down to Security).

If that doesn't work, then as a temporary measure try a different browser like Firefox. http://www.mozilla-europe.org/en/firefox/

If that fails, tell us about your security applications. For example I understand that the Kaspersky firewall has settings to block internet sites.

What other security applications do you have, eg anti-virus and anti-spyware?