Windows 7 forum

Question

Blocked connections booting normal, fine in Safe Mode...

by charliearthur1911 / January 5, 2013 8:51 AM PST

Hello all,

A few of my programs are unable to communicate with their servers now and I can't figure out why as they were find two weeks ago and I haven't made any changes since then. The issue lies with a service/program within Windows as all the programs communicate fine in Safe Mode. Windows Firewall and ICS are both disabled within Services. Malwarebytes (my only AV right now) is disabled also.

I know this is an ongoing and repetitive subject but the numerous searches are all resulting in pointing fingers at an AV program, which I am sure is completely disabled. Any help is appreciated.

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Blocked connections booting normal, fine in Safe Mode...
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Blocked connections booting normal, fine in Safe Mode...
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Try doing a clean boot
by wpgwpg / January 5, 2013 9:12 AM PST

Have you tried going into MSCONFIG and setting your system(s) to do a clean boot? Since things work in Safe Mode, I'd think it would be something in that startup list that's causing the problem.

Good luck.

Collapse -
RPC Endpoint Mapper??
by charliearthur1911 / January 5, 2013 2:14 PM PST
In reply to: Try doing a clean boot

Attempted to clean boot but now I cannot completely uncheck "Load system services" due to the following services running and give no option to disable or stop:

Group Policy Client
RPC Endpoint Mapper
Task Scheduler


I was able to reboot with "Load startup items" unchecked but the issue remained.

As stated in the title, the connections work fine under Safe Mode. After observing these three services not stopping, I went to Safe Mode and noticed the following:

Group Policy Client - "Stopped" with no option to Start
RPC Endpoint Mapper - "Started" with no option to Stop
Task Scheduler - "Stopped" with the option to Start


I researched the Remote Procedure Call(RPC) and the only thing I can think of that is remotely related and has been updated recently is TeamViewer 8.0.16642. I uninstalled it completely, rebooted and the issue still continues Cry

The issue must be be with the RPC Endpoint Mapper which makes sense. The problem is how to I troubleshoot further?

Collapse -
CORRECTION
by charliearthur1911 / January 5, 2013 2:19 PM PST
In reply to: RPC Endpoint Mapper??
CORRECTION: "RPC Endpoint Mapper - "Started" with no option to Stop" would technically mean that it is not causing the issue since it is "Started" yet the connections work fine. I am thoroughly confused now ConfusedConfused
Any further help would be appreciated.
Collapse -
With clean boot, keep the MS programs
by wpgwpg / January 6, 2013 2:56 AM PST
In reply to: RPC Endpoint Mapper??

In the Startup tab you can uncheck everything but the antivirus program, but in the Services tab, you want to first check the box that says "Hide all MS services" and don't uncheck any of them. If you unchecked any of those (e.g. RPC), I'd go back and check them because most of them are necessary, as you've discovered.

Good luck.

Collapse -
Done but still no luck
by charliearthur1911 / January 6, 2013 2:28 PM PST

In my message above, I tried what you are recommending but still no luck. I know it has to be a service/program that is starting with Windows in normal mode. The problem is that I am having a hard time narrowing down the culprits.

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Tech explained

Do you know what an OLED TV is?

CNET explains how OLED technology differs from regular TVs, and what you need to know to make the right shopping decision.