Windows Legacy OS

Question

BitviseSSH w/RDC Don't Render Wallpapers

by jimwg / October 9, 2012 10:14 AM PDT

Greetings:

I am having a peculiar problem on my WinXP-3 system relating to using Bitvise SSH and Remote Desktop Connection. I can run RDC as designed in my home net and it works great, only I'm concerned about wifi security in a high density neighborhood. Users recommended I use latest BitviseSSH client and server which makes RDC use a tunnel. Bitvise works well, only thing is it doesn't display wallpapers from the server. Actually it does in a flaky way if I first use raw RDC and log it off followed by Bitvise after a fresh reboot, but there must be an easier fix to that.

Below are fix-it suggestions that I originally followed which are really for RDC proper, not for Bitvise which is giving me the no-wallpaper problem:

----
First off, your RDP client (Remote Desktop Connection client in the case of Windows XP) has to have remote wallpaper enabled in your MSTSC settings. On XP, open the saved Remote Desktop Connection file to the server you are connecting and click the Experience tab. Place a check in the option Desktop background. This allows the client to see enabled desktop wallpapers.Second, connect to the remote Win2k3 server and from a Run box, type mmc to open the Microsoft Management Console. Click File -> Add/Remove Snap-in. Click the Add button, choose Group Policy Object Editor from the list and click Add then Close then OK.Now browse to Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Terminal Services. From the list, modify Always show desktop on connection to Enabled and Enforce Removal of Remote Desktop Wallpaper to Disabled. Now close the MMC clicking No about saving the settings.Log out of your remote desktop connection and login again, making sure your RDP client has desktop wallpaper enabled. Now you should be able to right click the desktop and apply wallpaper normally. I still recommend doing the colored background with the wallpaper since not all connecting clients will have desktop wallpaper enabled.

------

My issue seems based that it is some Bitvise config inhibiting RDC from displaying wallpaper, but I've no idea. I bounced between many user forums for recommendations so I hope I hit pay-dirt here!

Thanks for any assist!

Jim in NYC

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: BitviseSSH w/RDC Don't Render Wallpapers
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: BitviseSSH w/RDC Don't Render Wallpapers
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech Tip

Know how to save a wet phone?

It's not with a dryer and it's not with rice. CNET shows you the secret to saving your phone.