AVG

General discussion

AVG Update Failed - 'General Error'

by pcwiz11-23659341530367336 / March 2, 2011 12:42 AM PST

I'm trying to update my AVG but it keeps failing and displaying 'General Error'. What should I do?

I'm running AVG 10.0.1204, Virus DB version: 1435/3463 on Windows Vista SP2. If you need any more info then let me know.

Post a reply
Discussion is locked
You are posting a reply to: AVG Update Failed - 'General Error'
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: AVG Update Failed - 'General Error'
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
update log files
by Dusan_AVG / March 2, 2011 2:45 AM PST
Collapse -
Information
by pcwiz11-23659341530367336 / March 3, 2011 12:08 AM PST
In reply to: update log files

Thanks for your quick responce.

Windows Vista SP2
AVG 12.0.1204 Virus DB: 1435/3463
I also have Spybot Search and Destroy installed but have never had any issues before.
The only firewall I have installed is the Windows Vista built in one. Again, I haven't had any issues before.
I use a Broadband internet connection through LAN.
ISP is TalkTalk.

When I try updating it simply Displays 'Update Failed. General Error.'
I've found, compressed and uploaded the avgupd.log file here http://dl.dropbox.com/u/22524162/avgupd.zip but I couldn't find the file avgupdm.log in the folder.

If you need any more information then please let me know.

Collapse -
Screenshot
by pcwiz11-23659341530367336 / March 3, 2011 12:11 AM PST
In reply to: update log files
Collapse -
RE-
by Dusan_AVG / March 3, 2011 3:58 AM PST
In reply to: Screenshot
Collapse -
Fixed!
by pcwiz11-23659341530367336 / March 3, 2011 11:51 PM PST
In reply to: RE-

Thank you that has fixed the problem. Now when I update it says 'Update completed successfully. No new updates are available.' Thanks ever so much for your help!

Collapse -
I've got the same problem
by ZulerC / March 10, 2011 10:52 PM PST
In reply to: Fixed!
Collapse -
RE: I've got the same problem
by JiriF_AVG AVG Staff / March 13, 2011 8:18 PM PDT

Hello ZulerC,

analysis of the provided update log files revealed that a AVG registry entry has been damaged which is preventing AVG update to be installed. This situation is different than the one described in this thread originally even though the "general error" is reported in both cases.

Please proceed as indicated in this AVG Free Forum post to rectify the issue.

Thank you.

Collapse -
Thanks!
by ZulerC / March 15, 2011 5:32 AM PDT

Perfect, it updated just fine. Thanks Happy

Collapse -
I have this problem too, can you take a look at my log file?
by dakisan / March 25, 2011 2:00 AM PDT
In reply to: Fixed!
Collapse -
Uppate
by Dusan_AVG / March 26, 2011 9:55 PM PDT

Hello dakisan,

Log file points to error with updating LinkScanner database.

Please proceed with manual update of LinkScanner database as per this post.

If that does not help, please perform full reinstallation as described.

Should the issue still persist afterwards, provide us with fresh update log files.

Thank you

Collapse -
Similar problem and also looking for help
by AndyReynolds / May 17, 2011 3:36 PM PDT
In reply to: Uppate

Hello AVG Staff,

I have the same problem as the people above. I've uploaded both log files.

Windows version: Windows 7
AVG version: 10.0.1209
Virus db version: 1500/3644
Other antivirus software installed / previously uninstalled (if any): uninstalled Avast, Zone Alarm
Other protection software installed: Ad-Aware
The exact error message you are getting (if any): x Update failed. General error.

Thanks,

http://dl.dropbox.com/u/4284314/avgupd.log

http://dl.dropbox.com/u/4284314/avgupdm.log

Thank you very much.

Collapse -
Re: Similar problem and also looking for help
by Ondrej_AVG / May 17, 2011 4:04 PM PDT

Hello AndyReynolds,

Collapse -
Thanks!
by AndyReynolds / May 18, 2011 12:03 AM PDT

Thank you AVG Staff, that has fixed the problem! Love

Collapse -
I have an "update failed, general error", too
by DanH_44 / June 5, 2011 2:08 PM PDT
In reply to: RE-

Should everyone follow the instructions here for the Link Scanner DB, etc, or is it a case-by-case basis?

I have windows 7 Ultimate, 64-bit.

My log files are here:
http://cid-2ad82e130b511e0f.skydrive.live.com/redir.aspx?resid=2AD82E130B511E0F!105

Thank you!!

Collapse -
Re: I have an "update failed, general error", too
by Ondrej_AVG / June 5, 2011 3:57 PM PDT

Hello DanH_44,

Collapse -
Re: I have an "update failed, general error", too
by DanH_44 / June 6, 2011 3:05 AM PDT

I ran chkdsk and it reported no errors on the drive.

I tried to uninstall avg and got the message:
Updating in progress.
Running update must be finished before starting installation ...

Is there something I can do to get it to uninstall or should I manually remove the avgfiles or should I just begin a new installation on top of the old?

Thank you for helping!
Dan

Collapse -
Re: I have an "update failed, general error", too
by Dusan_AVG / June 6, 2011 4:17 AM PDT
Collapse -
Re: I have an "update failed, general error", too
by DanH_44 / June 6, 2011 7:52 AM PDT

Sorry, I didn't see the link the 1st time.

I removed old installations as directed and tried (twice) to install the new. I received the onscreen error message:

Error code: 0xC0070643
Error msg: General Internal Error
Additional msg: 0xC0070517
Context: MSI action failed

I saved the log file, AVGInstLog.cab at
http://cid-2ad82e130b511e0f.skydrive.live.com/redir.aspx?resid=2AD82E130B511E0F!105

Thank you!
Dan

Collapse -
Install still fails - Reply to Dusan_AVG - 6/7/11 9:22 AM
by DanH_44 / June 7, 2011 8:41 AM PDT

Hello Dusan,

I couldn't reply below - perhaps nested too deep? I changed the permissions on that folders as directed, but the install still fails.

Error message was slightly different this time (525 vs 517):
Error code: 0xC0070643
Error msg: General Internal Error
Additional msg: 0xC0070525
Context: MSI action failed

I saved the log files and AVGInstLog.cab at (msinfo from last night is still there):
http://cid-2ad82e130b511e0f.skydrive.live.com/redir.aspx?resid=2AD82E130B511E0F!105

The folders/files that were in use and couldn't be deleted were on the tree:
\Users\All Users\AVG10 ... I have since come to realize that this is in use because it holds the scan data for the drive from the working AVG instance from another leg of my dual boot.

Thanks for helping,
Dan

Collapse -
RE: Install still fails
by Dusan_AVG / June 7, 2011 6:50 PM PDT

Hello

There seems to be some user account issues on your computer.

Please try to enable administrator account temporarily, log into the account and try to install AVG.

If it does not help, create a new account with administrator privileges and attempt to install again.
Make sure to run AVG remover prior to each installation attempt.

If that still does not help, provide us with installation log files again (log file after installing using newly created account).

Thank you

Collapse -
Install still fails, x2
by DanH_44 / June 8, 2011 5:21 AM PDT

After 2nd installation failure, in newly created admin acct, new log files are at:

http://cid-2ad82e130b511e0f.skydrive.live.com/redir.aspx?resid=2AD82E130B511E0F!105

Thanks for helping!
Dan

Collapse -
re: Install still fails, x2
by Zbynek_AVG AVG Staff / June 8, 2011 10:08 PM PDT

Hello Dan,

In order to analyze your situation please provide us with GMER scan results and Screenshot of permitions you have changed.

Thank you

Collapse -
Full Re-installation Failed - "General Internal Error"
by DanH_44 / June 6, 2011 3:32 PM PDT

Hi Dusan_AVG,

I am re-posting, in case it wasn't clear from my previous post title that the re-installation failed (see prev post for details). Or should I be starting a new thread instead?

My problem is more urgent now, because now I have NO anti-virus protection.

Please help!

Thanks,
Dan

Collapse -
Re: I have an "update failed, general error", too
by Zbynek_AVG AVG Staff / June 6, 2011 7:49 PM PDT

Hello Dan,
According to provided log files there is some issue with creating shortcuts, please delete
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\AVG 2011 folder before installation.


If it doesn't help on your situation please provide us with Msinfo output and Installation log files.

Collapse -
I couldn't delete that folder - it doesn't exist
by DanH_44 / June 6, 2011 11:35 PM PDT

Hello Zbynek,

the Msinfo and log files are at:
http://cid-2ad82e130b511e0f.skydrive.live.com/redir.aspx?resid=2AD82E130B511E0F!105

BTW, before the failed install attempt, I tried to delete every instance of avg*.* on my computer. Some files could not be deleted (file in use), even when I exercised a dual-boot option into a different operating system.

Thank you for helping,
Dan

Collapse -
RE: I couldn't delete that folder - it doesn't exist
by Dusan_AVG / June 7, 2011 2:22 AM PDT

Hello DanH_44,

Installation again fails on accessing:
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\AVG 2011

Make sure that hidden files and folders are displayed as described in - How To Display Hidden Files And Folders.

If the folder is still not present, check access permissions of folder and its subfolders:
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\

Permissions need to be Full control for Administrators and SYSTEM.
How to change permissions is described here.
Please provide us with a list of files/folders you are unable to delete due to being in use.

Should the installation still fail even with fixed permissions, provide us with new installation log files.

Thank you

Collapse -
Permissions as directed but the install still failed
by DanH_44 / June 7, 2011 8:41 AM PDT

Hello Dusan,

Error message was slightly different this time (525 vs 517):

Error code: 0xC0070643
Error msg: General Internal Error
Additional msg: 0xC0070525
Context: MSI action failed

I saved the log files and AVGInstLog.cab at:
http://cid-2ad82e130b511e0f.skydrive.live.com/redir.aspx?resid=2AD82E130B511E0F!105

msinfo from last night is still there

The folders/files that were in use and couldn't be deleted were on the tree:
\Users\All Users\AVG10 ... I have since come to realize that this is in use because it holds the scan data for the drive from the working AVG instance from another leg of my dual boot.

Thanks for helping,
Dan

Collapse -
Permissions as directed, install still fails
by DanH_44 / June 7, 2011 8:41 AM PDT

Hello Dusan,

I changed the permissions on that folders as directed, but the install still fails.

Error message was slightly different this time (525 vs 517):
Error code: 0xC0070643
Error msg: General Internal Error
Additional msg: 0xC0070525
Context: MSI action failed

I saved the log files and AVGInstLog.cab at (msinfo from last night is still there):
http://cid-2ad82e130b511e0f.skydrive.live.com/redir.aspx?resid=2AD82E130B511E0F!105

The folders/files that were in use and couldn't be deleted were on the tree:
\Users\All Users\AVG10 ... I have since come to realize that this is in use because it holds the scan data for the drive from the working AVG instance from another leg of my dual boot.

Thanks for helping,
Dan

Collapse -
Permissions as directed but the install still failed
by DanH_44 / June 7, 2011 8:41 AM PDT

Hello Dusan,

Error message was slightly different this time (525 vs 517):

Error code: 0xC0070643
Error msg: General Internal Error
Additional msg: 0xC0070525
Context: MSI action failed

I saved the log files and AVGInstLog.cab at:
http://cid-2ad82e130b511e0f.skydrive.live.com/redir.aspx?resid=2AD82E130B511E0F!105

msinfo from last night is still there

The folders/files that were in use and couldn't be deleted were on the tree:
\Users\All Users\AVG10 ... I have since come to realize that this is in use because it holds the scan data for the drive from the working AVG instance from another leg of my dual boot.

Thanks for helping,
Dan

Collapse -
GMER results & screen shots for Zbynek_AVG - 6/9/11 5:08 AM
by DanH_44 / June 9, 2011 2:23 AM PDT
In reply to: update log files

For the GMER Autoscan, there was no screen display, nothing to copy and nothing to paste.

For the GMER full anti-rootkit scan, after about a half hour of scanning, the log file was zero length and couldn't be uploaded, see screen shot.

Screenshots are uploaded here:
http://cid-2ad82e130b511e0f.skydrive.live.com/redir.aspx?resid=2AD82E130B511E0F!105

Thanks for continuing to help,
Dan

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech Tip

Tired of your tricky Wi-Fi password?

Stop trying to memorize a complicated sequence of numbers and letters. Learn how to change the default password.