AVG forum

General discussion

AVG General error when updating

by junoty / March 17, 2011 2:09 AM PDT
Post a reply
Discussion is locked
You are posting a reply to: AVG General error when updating
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: AVG General error when updating
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Solved
by junoty / March 17, 2011 2:49 AM PDT

Solved thanks!

Collapse -
Re: Solved
by Ondrej_AVG / March 17, 2011 4:41 PM PDT
In reply to: Solved

Hello junoty,

I am glad to hear the situation was solved.

For others with general update error, analysis of provided information found in "avgupdm.log" file line:

MSI (s) (FC:CC) [11:55:44:882]: MainEngineThread is returning 1639
Info 1639. Invalid command line argument. Consult the Windows Installer SDK for detailed command line help.


This is already known problem and will be fixed with next cumulative program update.

Manual fix is available at this AVG Free Forum post.

Thank you

Collapse -
This may help
by SG1MAX / June 30, 2011 4:37 PM PDT

This is a FIX i have done many times for this AVG GENERAL ERROR



1 open AVG main screen
2 Go to TOOLS
3 Advanced Settings
4 Update
5 Click on URL

you will see 2 boxes ticked ( primary server ) and secondary server ) UN-Tick the primary box then apply and OK
you can now try and update Happy works for all the pC's i have used it on for this error.

Good luck

Collapse -
Re: This may help
by Ondrej_AVG / June 30, 2011 9:36 PM PDT
In reply to: This may help

Hello SG1MAX,

Collapse -
update - general error
by dougfield / May 8, 2012 3:15 AM PDT
In reply to: This may help

I tried to to the above, but the URL box is 'grayed out' and I can't uncheck either server

Collapse -
Re: update - general errror
by Ondrej_AVG / May 8, 2012 4:07 PM PDT
In reply to: update - general error

Hello dougfield,

Mentioned URL box is unchangeable in AVG Free Edition.

Can you please gather AVG update logs from affected station, upload it in an archive (zip file) to favorite online storage and provide us with link to it, so we can analyze the situation.

Thank you

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Smartphone tip

Hoarding photos on your phone?

Those picture are hogging memory and could be slowing down your phone.