Windows 7

Resolved Question

AutoPlay prompt gone

by trdavidson / November 24, 2011 7:31 PM PST

When I insert a disc or flash drive or memory card nothing happens. I must open My Computer to access files from any of the media.

trdavidson has chosen the best answer to their question. View answer »
Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: AutoPlay prompt gone
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: AutoPlay prompt gone
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Best Answer as chosen by trdavidson

Collapse -
Not a bug
by MarkFlax Forum moderator / November 24, 2011 8:33 PM PST
In reply to: AutoPlay prompt gone

There was malware that could infect the autorun on external discs or drives, and when AutoPlay loaded that, it could infect the system. So Microsoft disabled AutoPlay.

You can choose what to do with discs from the Control Panel > AutoPlay options. But just be cautious whenever using non-commercial discs that you scan then before autoplaying from them.

Mark

Collapse -
Not a bug
by trdavidson / November 25, 2011 2:55 PM PST
In reply to: Not a bug

Thanks, Mark

Collapse -
There was plenty of information about it
by MarkFlax Forum moderator / November 25, 2011 9:20 PM PST
In reply to: Not a bug

at the time, and also the vulnerability was solved via Windows Updates, so you would have had all the information available from Microsoft from the updates themselves

Mark

Collapse -
Well...
by trdavidson / November 27, 2011 1:36 AM PST

I guess I missed the memo... Blush

Collapse -
Not A bug
by garyu203 / December 2, 2011 11:06 AM PST
In reply to: Not a bug

I have not seen Microsoft disable Autoplay in Windows 7, only Windows XP and many third party programs will also disable Autoplay. After checking control panel and Autoplay still checked, its still disabled.
Go to Services, Shell Hardware MUST be set to AUTO
Hope this helps.

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech for the holiday

Find recipes for July 4 with these foodie apps

The Fourth of July means fireworks, fun and food. If you're planning on a barbecue this weekend, we've got the apps to help you find holiday-inspired recipes.