Forum Announcement

Welcome to the new CNET Forums! Please don't panic. You are not in the Twilight Zone, you are experiencing the new CNET forums platform! Please click here to read the details. Thanks!!

Computer Help

Question

Apps Service Running But No User Interface Appear on Screen

by starlegacy / January 29, 2013 10:14 PM PST

Hi All,



I have a client PC that is connected to a Domain, and the user level is Administrator Domain. The PC's OS is Windows XP SP2, 32 bit OS.



I wanted to install my company's software to my client's PC and it requires Microsoft Dot Net Framework v2.0 to be installed too. The software installation runs normally, both Microsoft Dot Net Framework and my company's software.

The problem occurs when i tried to run the application. In "Processes" tab of Windows Task Manager, the application is running and using computer's resources. In "Application" tab of Windows Task Manager, the application that i ran does not appear in that Application list. Usually the splash screen and the login screen will appear first on the screen before proceed to the main application window, and it doesn't shown up.

Other application that have been installed previously has no problem at all. The other application is running normally.

I've tried to run the reg fix from this thread:

"http://forums.cnet.com/7723-6142_102-295190/programs-won-t-run/" and no result on the client's PC.

User says that he did not wanted to reinstall the OS because there is one application (fingerprint software) installed on the PC, but the vendor has closed. So, there is no more support from Fingerprint software vendor to help us reconfigure the fingerprint software if any fixes disturbs the software.



I wonder what's the problem. Anyone can help me solve this problem?





Thank you.

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Apps Service Running But No User Interface Appear on Screen
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Apps Service Running But No User Interface Appear on Screen
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
It's time to contact the app's author.
by R. Proffitt Forum moderator / January 29, 2013 11:44 PM PST

I write .NET apps and when this happens I have to be contacted to see if it's something I didn't account for on some machine. The clues here are insufficient and it's probably something the author needs to address.
Bob

Collapse -
Application Not Appeared On The Screen
by starlegacy / February 3, 2013 2:06 AM PST

The problem is:
My company's application is not running properly, like showing the login screen or the splash screen. On the screen i can't see any of my application window (e.g. login screen or splash screen or lnitializing the application components progress). I don't know why it happens, because the installation itself works normally and no problem at all.
Then i check my application on Windows Task Manager > tab Application, and there is no my application name (Pay Master Enterprise Version) on the Application Tab list. So i check the Processes tab and there is my application name (Andal.PayMaster.exe) is using computer resources, but where is my application screen? i can't see it.

Some actions that i have done to that PC:
- Virus Scan: The virus scan shows no sign of any infected virus or malware.
- Upgrade Service Pack: Upgrade the service pack from SP2 to SP3 did not have any effect.
- Setting Folder Security: user as "Everyone" with permission level "Full Control - Allow" checked did not have any effect too.
- Running the application Locally (The Client's Local PC User) or from User Domain also did not have any effect.
- Installing Advanced System Care to scan registry fix also did not have any effect.
- Running Exe & Lnk file association, reg exe fix also did not have any effect.
- Repair Microsoft Dot Net Framework from "Run" > "Installer" did not have any effect.

The application requires Microsoft Dot Net Framework v2.0 to run properly, and it already installed without any problem.

Any other suggestion what should i do to that PC, so my company's application can run normally?

Collapse -
Not yet.
by R. Proffitt Forum moderator / February 3, 2013 2:28 AM PST

If an OS reinstall fails then I have to look harder at the PC in question. One issue I bumped into with my app is when there is an onboard video and the user installed a video card. Because they didn't know how to configure such, apps could start on the other screen which is not attached. We charged a fee for the trip out to correct their hardware. They yelped but it wasn't our app at fault since other apps did it too.
Bob

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech Tip

Tired of your tricky Wi-Fi password?

Stop trying to memorize a complicated sequence of numbers and letters. Learn how to change the default password.