Sounds like somehow or another the PDF extension was set to Notepad or whatever. So, right click any random PDF file, go down to the "Open with..." menu option, and then the "Choose default program" if there's a list, otherwise just click the "Open with..." From there, if Acrobat Reader isn't in the list, hit the browse button, find the executable for it, and then hit the Open/OK buttons until you're done.

Other options would include reinstalling Acrobat Reader to reestablish the file type association, installing a (IMO superior) third party alternative like Foxit Reader to again reestablish the file type association, or you could simply open PDF files from within Acrobat Reader (or any other PDF capable program). File type associations are just a matter of convenience, they don't affect the contents of the file whatsoever.