Computer Help forum

General discussion

4/29/05 Why is my computer busy at work when I'm not?

by Lee Koo (ADMIN) CNET staff/forum admin / April 26, 2005 4:50 PM PDT

Thanks to all of you who contributed to this past week's Q&A topic.
Pitura, I hope this week's members' recommendations give you some direction to your concerns. And if you have a moment, please join us in the discussion below, to let us know if these provided answer helped out in anyway.

Members, if you have more questions, or additional advice on this topic, by all means feel free to post them in this thread below. It?s all up to you as a community to contribute and learn from one another. So keep on posting.

Thanks everyone and have a great weekend!
-Lee Koo
CNET Community


Question:


I'm running a P4 2GHz PC Windows XP system with 256MB of RAM.
Periodically while the system is not being used, I notice the
hard drive light flashing and it sounds like some sort of
intensive file read/write is going on. I open the Windows
Task Manager Processes window to find out what is
running, and the only service that is consuming the CPU is
the system idle process, very high around 95 to 98 percent.
Also, as soon as I open this window, the hard drive stops
acting busy. I have Norton AntiVirus, Spybot, and the
ZoneAlarm firewall installed and running, but these don't
appear to be what's keeping my CPU busy. There are no open
applications on my taskbar either. What else could it be?


Submitted by: Pitura


Answer:

Hi Pitura,

What you are witnessing, if you have not scheduled any other background tasks to run while the system is idle, is the XP Indexer at work. The dead giveaway is the fact that your HDD stops the activity as soon as you start another activity. It kicks in periodically only when your processor is otherwise idle. The purpose of the Indexer is to speed up your file operations. If you have a large number of data files, say hundreds, having their location indexed by the system could be beneficial, at least in theory. If you don't have a large number of files in your My Documents folder or other data files, you might consider turning the indexing off.

Click the Start button.
Select Run.
Type in services.msc and click OK.
Select Indexing Services.
Change Startup Type to Disabled.
Close the Services Window.

Regards,
Matti

Submitted by: Matti S.

Post a reply
Discussion is locked
You are posting a reply to: 4/29/05 Why is my computer busy at work when I'm not?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: 4/29/05 Why is my computer busy at work when I'm not?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Honorable mentions
by Lee Koo (ADMIN) CNET staff/forum admin / April 26, 2005 4:50 PM PDT

*** HONORABLE MENTION ***

Answer:

It could be a number of things. Most likely, it's just Windows itself.

Windows has this thing called a "delayed cache write" meaning that SOME things do not get written to the hard drive immediately. The purpose of this is to speed the system up by not forcing the system to immediately dump everything to the hard drive when CPU cycles are needed for other operations. When the system is idle, Windows catches up and flushes the buffers to the hard drive. By interrupting (moving the mouse/touching the keyboard/etc...) you're diverting the CPU from whatever it was doing - which is why it stops when you do that.

As for the Task Manager and the "System Idle Process" service - that is (as the name suggests), nothing more than the electronic version of twiddling of one's thumbs. The system is doing nothing - ergo, idle. The percentage of idle processes is about average for a system doing nothing. Look for the OTHER tasks sucking up the CPU's cycles - those are the services that are probably causing the lights to flash.

OR... Since you didn't mention if you've got broadband - and if so - if it's active or not during this time. It could be that you've had someone attempting to connect to your computer and Zone Alarm has neutralized the threat (it's usually over in less time than it takes to blink) and ZA is writing to it's log.


Submitted by: Pete Z.

***************************************************************************

Answer:

Could be any of a myriad of things going on. The easy ones that come to mind are Windows indexing service which if turned on could be indexing all the files on your system while the system is idle. It could be your virus scanner which may be set to scan while idle. The fact that it stops when you wake the machine tells me that it's probably not nefarious. Oh yea. That system idle process is just a process that counts when you system isn't doing anything. It's a good thing when it's high.

Submitted by: Anthony C.

***************************************************************************

Answer:

Pitura,

During idle time there are many factors that would make the hard drive spin up, depending on your operating system's configuration, it could be anything from a simple screen saver program getting ready to load, to the scheduling managers of your background software that already is loaded. These schedulers usually default to a 'run on idle' setting when you install them, and you have to make a conscience effort to check the preferences of each of them to determine if it's something you want to happen, and at which time you REALLY want them to occur.

Your anti-virus, spamware, firewall, any chat programs you have that load on startup all check for updates if you have a broadband or 'always-on' connection. Even your audio and video drivers, that you may think are just 'dumb' files and dormant, are not necessarily so, in this day of update and upgrade. Check your programs carefully to see whether they are set to check at idle, and even XP itself. I'm sure you will find more than one culprit!


Submitted by: Royce C.

***************************************************************************

Answer:

What is happening is the computer has determined that you are not in the process of using it, this happens after a period of inactivity. What you are seeing is background services doing disk maintenance, Indexing the drive, doing file archives etc. You can see where these processes are activated for the file system by Right clicking on an icon and selecting properties and clicking on the advanced tab under the general heading.

When you check the computer, it sees you as being active finishes what it was currently working on and waits for you to become inactive again. To index and archive any changes you have made.

Hope this helps.

Submitted by: Larry E.

***************************************************************************

Answer:

-Virus scanners, DEFRAG programs, etc. Some of these programs will ask you during the installation procedure if you want to allow them to operate in the background, or during periods when the system is in screen-saver mode. The implication of course, is that the best time to run these CPU-intensive or hard drive-intensive programs is when YOU are not using the machine for something that might get bogged down by these operations.

Let's face it. If you determine that a DEFRAG program is slowing down your computer while you are doing something important, you might be tempted to chuck the DEFRAG program (and tell your friends too). Go through your installed program list and look for programs that would most likely be hard-drive intensive programs and then check the "Preferences" or the "Options" or the "Settings" of each. Programs to look for would be things like: a) DEFRAG programs, b) anti-virus scanners, c) spyware scanners, d) ad-ware scanners, e) disk cleaners, and f) system optimizers.

Submitted by: Jim P. of Hillsborough, NJ

***************************************************************************

Answer:

Pitura,

There are many things that could be going on here and I will try to break it down as best as possible. First XP could be backing up important system files, Then Norton Antivirus (which is always on unless you stop it) could be running a scheduled checkup, Spybot also could be running a scan. XP Windows could be downloading/installing updates from Microsoft which is also on schedule unless it was turned off or configured otherwise.

To find out about what is running automatically, right click "My Computer" (icon), select "Manage", click the plus sign to expand "Services and Applications" then select "Services" This will display all the services that are running, stopped, started, or can be manually started.

Unless you really know what you are doing I do not recommend that you make any changes to your system from here, but this should give you a good idea of what's going on in your computer besides just trying to find files located on a Hard Drive.

I hope this helps solve your curiosity of the activity lights on your PC.

Submitted by: John B.

***************************************************************************

Answer:

The system idle process to my understanding. The reading on the CPU usage in the Processes tab of the Task manager is not really accurate. This column has some outside influences that art obvious at first. To begin with, the 98% usage seems to only apply to allocated memory for that process. Programs are obviously in the 1.0 MB and above range, while system idle process (SIP) only has 16k. If you watch it while your computer is on and you are working on it, you will see that it runs at 80% constantly while the performance tab shows far less than this for
actual CPU usage.

It seems to monitor and keep track of small changes in your system, new files, moved files, virus quarantines, etc. Once the system into idle mode from lack of use, it goes to work. I believe that it spends computer down time updating the system register, the Indexing service, and several other things window does to maintain itself. The intense sound comes from it doing it as fast as possible, because it doesn't know when your computer will leave idle mode.

Submitted by: Mysteic

***************************************************************************

Answer:

There are 2 potential causes that fall under normal behavior.
1. Typically on a machine with only 256 MB of RAM and all those protective services (anti-virus, anti-spyware, firewall, etc) your system will be using some swap space (virtual memory) to extend the available memory.
What this does is watch for idle processes that are using memory and move those processes from RAM to swap to make room for active processes as RAM is significantly faster than swap.

2. Modern operating systems and disk drives/controllers like to use delayed-write caching. A program will want to write to a hard disk, the system will report that it completed, but instead it just keeps track of it so when the system is idle or less busy (low disk activity, etc) it will then write everything it has cached to the disk. This is part of the reason why Windows 98 & Windows ME will automatically check your disk after a bad shutdown. It wants to try and clean up any inconsistencies of files that were open or were not written from cache.

What you are experiencing is most likely a combination of the two.

Submitted by: Michael L.

***************************************************************************

Answer:

This runs periodically, but only when the system is idle.
That's why as soon as Task Manager is open, the hard disk access stops.
This can be disable by right clicking on all the partitions and unselecting the *Allow Indexing Service to index this disk for fast file searching*. If this feature is to be disabled completely, the *Index
Service* can be stopped from the *Services* icon in *Control Panel -> Administrative Tools*.

Another culprit might be Microsoft Office's FindFast utility. This indexes documents for faster access during searches. This can be removed from the *Control Panel* by selecting the *FindFast* icon and deleting any jobs/indexes that might exist. (Please note that FindFast is part of Office'97, I don't know if latter versions has this feature as I don't have access to them.)

I hope that the above answer's Pitura's question.

Regards

Submitted by: Paul S.

***************************************************************************

Answer:

It is Indexing service, which is causing this problem. Indexing service builds indexes of documents on your hard disk so that while searching response becomes faster.
You can safely disable this service. Just Go to Control Panel > Administrative Tools > Services. Find Indexing service and double click it.
In the startup type, choose "Disabled". Click OK and restart the PC.
Problem should go away.

Submitted by: Arvind K. G. of BHEL Haridwar India

Collapse -
Computer slowdowns
by Douglas Naylor / April 29, 2005 12:47 AM PDT
In reply to: Honorable mentions

A frequently overlooked area is a friendly hijack by such programs as anti virus software which will tie up processor speed searching for definition updates. I have found this to be most annoying and prevalent with all types. My last instance was with Norton Anti virus. I had for convenience sakes clicked notify me later for a subscription renew. My laptop was tied up as the renew subscription concept pushed itself to the top of the job status and devoted nearly 98% of processor tie trying and re trying an expired subscription status. Be careful how you install the packages. Automatic updates are fine if the subscriptions are kept current.

Collapse -
computer keeps on working while Im not
by vecsoto / April 29, 2005 11:25 AM PDT
In reply to: Honorable mentions

Even idle your computer is still working might be ude to :

1.) If your using DSL or dial up is ON or you might have left it connected, configuration dial up when line is present or a sort of someone might be remotely accessing your computer remotely.

2) too many files are detected by indexing, defragmentation facility is in action.

3) check if your screen saver is not configured properly

4) If your using service pack 2 of XP you might have turned ON Downloading update AUTOMATICALLY, features are currently applied.

5)Your RAM. your previously activated programs may still be running sort of delayed, i experienced it before when i used to have a RAM less than 512Mb using a 120Gb segate ST3120022A though it was 7200rpm it seemed always working too large and because my RAM was only 256Mb accessing diles and closing it as idle is the same speed.

Vic

Collapse -
computer keeps on working while Im not
by vecsoto / April 29, 2005 11:35 AM PDT
In reply to: Honorable mentions

Even idle your computer is still working might be ude to :

1.) If your using DSL or dial up it is probably ON or you might have left it connected, configuration dial up when line is present or a sort of someone might be remotely accessing your computer.

2) too many files are detected by indexing or defragmentation facility is in action.

3) check if your screen saver, power settings is not configured properly

4) If your using service pack 2 of XP you might have turned ON Downloading update AUTOMATICALLY, features are currently applied.

5)Increase Your RAM. your previously activated programs may still be running sort of delayed, i experienced it before when i used to have a Physical RAM less than 512Mb (in my case of P4 im using a 120Gb segate ST3120022A though it was 7200rpm it seemed always working too much for too large files) and because my RAM was only 256Mb accessing and closing files has the same time i spent more time and when it was idle i had your same problem as your experienced. I increased it to 512Mb and presto... no more lights.... LED signs of idle work for my computer....

Vic

Collapse -
Additional advice from our members
by Lee Koo (ADMIN) CNET staff/forum admin / April 26, 2005 4:50 PM PDT

****Additional advice from our members ****

Answer:

Pitura,

If you hear disk activity while the system is truly idle, it is most likely the diagnostic service routine of your hard drive. Most disks have firmware routines that periodically run when the disk is spinning but has not been accessed for a while (i.e. several minutes). These routines check for hardware errors and update the S.M.A.R.T. statistics tables for the drive which can be used to detect impending failures.

Submitted by: Dave F. of Stillwater, Oklahoma

***************************************************************************

Answer:

Windows XP has a feature called system restore. This function allows you to roll back your system configuration to a previous time. Windows uses idle time to gather information about the current state of your system. This is most likely what is causing the disk activity. You can test this theory by TEMPORARILY disabling system restore. This is done by going to Start->Control Panel, opening the system icon in the control panel, and selecting the system restore tab. There is a check box on this screen that allows you to disable system restore. After disabling system restore, wait the requisite amount of time and see if the disk activity continues. If this is the cause, I woud NOT recommend leaving system restore off.

The excessive noise coming from the hard drive is most likely caused by excessive fragmentation. Fragmentation occurs when different parts of different files are scattered throughout the hard disk. This causes the read/write heads to have to jump back and forth causing the loud noises you describe. Defragmenting your hard drive often (at least weekly) can help alleviate this problem. You can use the windows defragmenter located in the system tools program sub-group of the accessories group, but i prefer the commercial defragmenter DiskKeeper. It allows you to multitask while you are defragmenting; it also gives you the option to schedule regular disk defragmentations as often as you desire.

Hope this helps,

Submitted by: Derek J. of Birmingham, AL

***************************************************************************

Answer:

The answer to this persons question about the mysterious hard drive activity after the computer is not in use is quite simple.

No, the hard drive is not possessed. You computer has what is know as a swap file. This is a file used to hold files that your computer might need in ram soon, but not quite needed yet. Even though lots of ram can be helpful, your computer still uses this swap file as a "go between" so that it doesn't have to sift through the files on your hard drive that it might need.

Imagine it this way:
Your computer is a carpenter. It has it's own workspace, complete with a work bench (processor), Tools on the tool hangers above the tool bench (RAM), tool box (Swap file on your hard drive), and outdoor shed (normal hard drive files).

When your computer is working, it is using it's processor (workbench) and and ram (tools on the tool hangers). Now when it comes to a file it might need, but doesn't need right at the moment, it runs to the hard drive files (the outdoor shed) and puts them into it's swap file (tool box). When it comes to the point that it needs the file it brought into the swap file (the tool box), it goes and gets it (which is why sometimes a program can take a long time to load... sometimes the file is in the swap file (tool box), and sometimes it's still in the normal program files in the hard drive (outdoor shed). Computers are terrible guessers, that is why they have such a variance.

Well, when you computer is not in use... it decides to clean up its ram, swap file, and hard drive... placing stuff back where it should be. So... sounds like it should be quiet after a minute, right?

wrong. That little "smart chip" that's known as the processor doesn't think that your away. Therefore, while it is guessing what to do next, it's also rearranging files. When it rearranges files, it sees it doesn't need certain ones, and puts those back to get others....
a circle? you bet!! Why doesn't it do this all the time? Simple.. a timer tells the computer when to start this activity.

Not the best of answers.. but I hope that this helps. I really hope that the whole "work bench and tools" example wasn't too confusing. It's a basic answer, not too technical. But I hope this helps!!!

Submitted by: Chris K.

***************************************************************************

Answer:

Most likely the windows indexing service is accessing your hard drive to index your files. You can disable the service by going to administrative tools in the control panel and clicking on services.
Double click on the indexing service. Under the startup type choose disable.

Another way to disable indexing is to double click My Computer. Right click on your hard drive and choose properties. Uncheck the "Allow Indexing Service to index this disk for fast file searching" box and click OK. Choose to apply changed to all sub folders and files.

Submitted by: Jonathan R.

***************************************************************************

Answer:

Dear Pitura & CNET friends


One of the cause of hard drive flashing is swap file window use when there is not enough RAM

It allows Operating System to use hard drive space to simulate extra memory.When system runs low on memory, it swaps section of RAM that an idle program is using onto hard drive to free up memory for other program. Then when you go back to swapped out program , it changes places with another program in RAM.
This causes large amount of disk Read/Write operation

On its own window creates dynamic swap file size.
The files grows and shrinks as needed. This results in long burst of hard drive activity with window automatically adjusting size of swap file.

You may refer to http://www.informationweek.com/shared/printableArticle.jhtml?articleID=12803483

and

How Virtual Memory works on www.howstuffworks.com You may visit www.pcguide.com Computer Encyclopedia at www.computerlanguage.com

*Regarding your issue of System Idle process & high CPU usage please refer to this link

http://www.pcworld.com/howto/article/0,aid,118232,00.asp

It recommends running System Idle Process even if it's huge. The process shows the percentage of CPU cycles that are not in use, so in this case, the bigger, the better

Above link also suggests link to Spybot Search & Destroy antispam download

http://www.answersthatwork.com/Tasklist_pages/tasklist_s.htm About system Idle and http://www.answersthatwork.com/Tasklist_pages/tasklist.htm About every entry in Task Manager.

This page also suggest running Sys Idle process

http://kadaitcha.cx/high_cpu.html

It also suggests high usage of CPU at idle time is okay if your system is responsive

http://www.wown.com/j_helmig/wxptskmg.htm

http://support.microsoft.com/default.aspx?scid=KB;EN-US;q317751
Microsoft Support


http://www.pacs-portal.co.uk/startup_content.php#HOW_CAN_I_IDENTIFY_THESE_PROGRAMS?


Best Regards

Submitted by: Ashar B.


***************************************************************************

Answer:

I would say that is windows file indexing system running during idle time.
Its job is to keep all the files on your hard drive indexed so file searches run faster.

This can be turned off but since it generally runs during idle time it is not taking away system resources.

I can understand though how someone would be concerned about the mysterious activity, since this activity can look just like spyware doing its thing in the background. I guess I wouldn't rule that out completely though. Make sure you run regular spyware checks with good software.

Submitted by: T.K.

***************************************************************************

Answer:

Pitura Query,
First point which I query is how many Hard Drives and what sizes ar they. If you have more than one the following processes are continiually monitored in the background, which you do not see. These being Off Line Files & System Restore.

If you follow these procedures.

1, Start - Control Panel- Open System then System restore tab, you will note under drive settings whether system restore is being monitored. If it is being monitored check the Turn off System Restore Box and apply.

2. Disable Off Line Files Start- Control Panel - Open Folder Options check to see if there is an enable Offline Files Box. If this is enabled, check it to turn it off. If the bow does not appear Close then open User Accounts if the Use Fast User Switching is activated disable it by clicking on same. (This may affect other users if that is the way your computer is set up.) If you are the sole user it will not affect you. Re-open Folder Options Folder aand ensure that the enable Offline Files is not checked, if so disable it. Apply any changes if requested, close open folders and restart your computer. This should solve the problem.

Finally I would suggest you upgrade you DDR memory to half a gig as this will allow you more acess to memmory and enable you to open and run several programs without major cpu usage.

Hope these tips work and happy computing
Regards

Submitted by: Ralph

***************************************************************************

Answer:

If you're using Windows XP the system requirements will be as follows:
Here's What You Need to Use Windows XP Professional
taken from http://www.microsoft.com/windowsxp/pro/evaluation/sysreqs.mspx

? PC with 300 megahertz or higher processor clock speed recommended; 233 MHz minimum required (single or dual processor system);* Intel Pentium/Celeron family, or AMD K6/Athlon/Duron family, or compatible processor recommended
? 128 megabytes (MB) of RAM or higher recommended (64 MB minimum supported; may limit performance and some features)
? 1.5 gigabytes (GB) of available hard disk space*
? Super VGA (800 x 600) or higher-resolution video adapter and monitor
? CD-ROM or DVD drive
? Keyboard and Microsoft Mouse or compatible pointing device

In my experience the above requirements from Microsoft it self is not so true. Windows XP alone will eat up all the memory you have on your pc. Even at 256 MB of RAM and with out all the software you've mention your pc still feels like it's crawling. Added to that you have that pesky Norton Anti Virus which uses up all your resources.
Though you might not see any applications running in front of you there are tons of background processes that eat ups your memory. The services, some of these services are starting up automatically as you startup windows. You might want to turn off any services you thing you don't use. If you do this be sure to remember which service you turned off your pc might not operate well after you've switch these services off. Try surfing this site www.blackviper.com/ here you'll see what are these service and what are they for.

Going back why i included the system requirements, true you have 256MB of RAM, but with your anti-virus and your desktop firewall you might want to upgrade your memory to 512MB better yet to a gig Happy

I think this is one of the greatest scam of what pc sellers/vendors fails to inform consumer. That when you have all the crap and stuff on your pc with a basic 128MB or256MB of memory and your OS is Windows XP you wont even feel the power of a P4 processor. You'll be crawling big-time. Each software takes up memory (see the system requirements for each software) and visualized what will it do with a 256MB of RAM.
Hope that helps.

Submitted by FUgly:

***************************************************************************

Answer:

Normally, whenever your system is idle for a period of time, Windows XP will use this idle time to defrag, or optimize your hard disk. This way, files and software should open faster. While most people like this task there are ways to disable this feature. The best way that I have found is using a program called Tweak UI. There is an option in the Tweak UI program that allows you to dissable this feature from optimizing your hard disk when your computer is idle.

Hope This Helps!

Submitted by: Mark R.

***************************************************************************

Answer:

My best guess is that Windows is reorganizing your files on your hard drive.
There's a function in windows that let it defragment your hard drive while the computer is idle. If you say that is stop work when you look at task manager, it most certainly means that the auto-defrag stop working because you took control of your computer and therefore is no longer idle. Now, if you wish to deactivate this function, it's possible to do so. While I wouldn't recommend it, here's how:

First, you'll need to download a little tool made by Microsoft called TweakUI. It's a small application that let you configure about everything from the user interface that is not covered in the control panel. You can fetch this program form here:
http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx
(this is the powertoys for windows XP)

Second, once you've installed and ran the program look for "General" on the panel on the left and look for "Optimize Hard Disks when idle" (Second form bottom), Uncheck and reboot. That should take care of your problem.

Have fun!

Submitted by: Mathieu D-E.

***************************************************************************

Answer:
Hi Petura,

You are not the only one to notice that your computer seems busy when you are not asking it to do anything. And Windows, for all its functionality, plus your other monitoring applications don't tell you much either.

A few possibilities:

1. Virus, worm, trojan or spyware activity. Many of these malicious applications ("malware") have their own agendas, which include searching your disk, phoning home, attacking other computers, or sending copies of themselves to the people in your address book. These are unlikely in your case because you have a strong anti-virus product running (and presumably up to date!), a spyware scanner, and a firewall. You would probably have mentioned that you noticed activity on your modem or a 'Traffic' indication from Zone Alarm during the time your disk was active. That you did not provides additional confirmation that the activity is not related to Internet communication. By the way, you might supplement the capabilities of Spybot with Ad-aware, another popular and free scanner available from CNET's sister service, www.download.com. The two scanners work in different ways and each picks up some spyware applications that the other misses.

2. Your Norton Anti-virus product is another possibility for the activity, because it has a feature allowing it to scan existing files when the computer is not otherwise busy.

3. Finally, you may have the indexing service turned on for your hard disk. This is a Windows feature that significantly speeds searches for files (RUN | SEARCH) by indexing the contents of the disk during idle time.

Because you are taking proper security precautions, the activity is most likely to be housekeeping rather than malicious.

Submitted by: Bob

***************************************************************************

Answer:

Dear Pitura,

I think I know what your PC does when it is not used for a little while. Mine does the same, so I went searching. Indeed, it is not the Norton, SpyBot, or the Zone Alarm, or any other program or service in the Windows Task Manager Processes window.
What I found is that Windows XP has a built-in option that optimizes your hard disk when it is idle. This option is normally 'on', so that's what your machine is doing after a few minutes not being used. You can easily configure this option with the free power toy TweakUI from Microsoft Downloads / Power toys and Add-ins at:

http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx

After you downloaded and installed the TweakUI.exe, the program appears in Start/Programs/Power toys for Windows XP/TweakUI. Open the program by clicking it, then go to "General" in the folder-list on the right. On the right you see a window called "Settings". When you scroll down, you see the setting "Optimize hard disk when idle" checked. This setting allows Windows to rearrange files on the hard disk when the computer is not in use to improve performance. So I leave it on, but if it annoys you, you can uncheck it here. This is a system wide setting which requires a restart for the change to take effect.

Important note:
It is possible that you need to be logged in as "Administrator" or an administrator account (not limited), because TweakUI shows fewer options for change when you are logged in as a limited user than when logged in as an administrator.

I hope that I've helped you with this and good luck.

Kind regards,

Submitted by: John from Woerden, The Netherlands

***************************************************************************

Answer:

Pitura,

The flashing indicator light usually means that your system is/or
1. Indexing the drive contents
2. VMM going through pagefile
3. SystemsRestore - making backup of your system configuration.
But, since you did not mention if your monitoring system reports high CPU usage on a domain controller, I would suspect that your PC has been overclocked and should be reset.


Submitted by: Rod M.

***************************************************************************

Answer:

Well Pitura,

I?ve also wondered what my computer was doing while I?m not on it. I did some research and found that Windows XP is the culprit, not your spyware programs, although they could contribute. Windows XP automatically indexes your hard drive while your computer is ?idle? (while you?re not on it). This is a very resource intensive program that makes the searches of your hard drive faster. While it?s running, your hard drive will be working very hard, and even your processor, however, as soon as you touch your computer, it will cease to be idle and XP will stop the process. You can disable this feature of XP if you wish. Start>Control Panel>Performance and Maintenance (Make sure your in category view)>Administrative tools>Services. You should see a long list of things. Click one of them and type ?In? that will bring you down to the ?I? section of the list. Then find ?Indexing Service.? Double click it and a new window will appear. In the ?General? tab, there should be an option for ?Startup Type?. Click on the combo box and select disabled. Click ?OK?, then restart your computer.

Submitted by: Brenton H.

***************************************************************************

Answer:

Pitura,
It could be a background process.
Bring up the task manager.
Click the "Processes" tab.
Look at the columns for "I/O Reads" and "I/O Writes".
(If it's not showing select the "view" menu option, click select columns and click on "I/O Reads" and "I/O Writes").
Click on one of the column headers to sort high to low.
Google unfamiliar processes (from the "Image Name" column) that are heavy I/O users to get info about them.
Good hunting!

Submitted by: David K. of North Haven, Connecticut, USA


***************************************************************************

Answer:

One of the things most likely causing drive activity while the system is idle is the Windows XP System Restore Utility setting a System Restore Point. Typically, it does this when a specific event occurs, such as installing a driver or program, or when the system is idle. What you?ll want to do to look at the System Restore Utility and check the date and time of any Restore Points, and see if they correlate to when you?ve noticed the disk activity while idle. To do that, click on Start, then All Programs, then Accessories, System Tools, and finally System Restore. Make sure the radio button next to ?Restore my computer to an earlier time? is selected and then click ?Next?. What you should see next is a window with a calendar on it, and next to is a description and time of any System Restore Points that were set. What you?ll then want to do is click the day on the calendar on which you noticed any hard drive activity, and look in the box to the right to see what time any Restore Points were set.

Submitted by: Alex T. of Lincoln, NE

Collapse -
Suffering from the same problem
by yosi7 / April 28, 2005 7:20 PM PDT

My notebook with 1.7MHZ CPU, 512MB RAM Windows XP and same anti-virus and anti-spyware protections suffers from same syndrome but unlike Pitura's case the flashing never stops and performance is deteriorated slowing programs, browsing, delay in opening programs, typing delays, mouse freezing etc. I disabled the File Indexing but no improvement is shown. Will appreciate any advice to locate the cause for this behaviour and help to solve the problem. Thanks. Joe.

Collapse -
Busy Hard Drive, Slow performance
by TomahawkZA / April 28, 2005 9:40 PM PDT

This could happen if there is insufficient space available on the Hard Disk Drive for the virtual memory or Windows swop file, and also if the files on the hard drive become overly fragmented.

Delete unwanted files, empty the recycle bin, delete temporary internet files, delete the contents of the windows temp directory.

Disable the windows swop file. (Set to 0MB)

Defragment the hard disk.

Reset the windows spop file (About 4GB should be adequate).

Check the startup folder and remove any unneeded utilities.

This should help.

Collapse -
Computer slowdown
by sharonhstephens / April 29, 2005 1:00 AM PDT

I've found that computer slowdown is also due to adware, spyware, or viruses. Run LavaSoft's free Ad-Aware and SpyBot to get rid of the spyware and adware. Be sure to check your PC for viruses with McAfee or use the free Avast (caught many Trojans McAfee didn't find). You will want to run the first two programs at startup if told that they found but couldn't remove certain ones because they were in memory. Just check the programs' options to run at startup, or go to safe mode and run the programs.

Hope this helped!

Sharon H. Stephens
www.forsalebatonrouge.com
www.tigerpages.com

Collapse -
XP Indexing
by ricster1963 / April 28, 2005 8:43 PM PDT

What if indexing is set to manual and the same scenario occurs?

Collapse -
Humanoid-Pentium!
by FastPolloMon / August 7, 2012 11:18 AM PDT
In reply to: XP Indexing

You should see what your activity light does when you hook up an external 1TB hardrive that is fully loaded! My CPU works overtime every night and all day when I am at work trying to keep up. Don't let it bother you, as it is for your own benefit. I know this is an old thread but hey - I'm still rocking XP!

Collapse -
How to disable indexing service for CD-ROM / DVD drives?
by Maansson / April 28, 2005 9:21 PM PDT

I have the same problem, but while I can disable each harddrive independently using the described methods, I'm still unable to disable the CD-ROM and DVD drives.

And as you may know, explorer also has a habit of not responding before it has spun up each CD-ROM and DVD drive to check what's in it, even though you are only exploring your harddrives.

So how can disable this annoying behavior as well?

Best Regards
Morten Maansson

Collapse -
Nobody??
by Maansson / May 2, 2005 6:30 PM PDT

I was hoping someone would have some insight?

Best Regards
Morten Maansson

Collapse -
Same problem win Win2k
by chocl203 / April 28, 2005 10:51 PM PDT

Hi,
I have a similar problem in Win2K. Do I use the same method to stop this action?

Collapse -
A few notes
by PlatinumPPC / April 29, 2005 12:02 AM PDT
In reply to: Same problem win Win2k

Just a few notes. First, at idle, it is likely the indexer that's running the hard drive light, there is another problem that will cause overactivity on the hard drive. The originally posted question included brief system specs. A windows xp system with 256 Mb of ram is ram starved. A minimum of 512 Mb of ram should be used with a windows xp based system for everything to run smoothly. A 256 Mb stick of ddr is a very inexpensive upgrade to your machine particularly if you install it yourself. (A very easy install even for a novice, there are several tutorials on the major manufacturers sites.) Running on 256 Mb of ram, you'll leave the O/S no option but to resort to using the pagefile or "virtual ram" a portion of your hard drive reserved for the O/S to use like ram. The problem with this is that physical ram is dramatically faster than pagefile ram, and in addition, there's the extra unnecessary thrashing on your hard drive to think about. It gets more commplicated than that in practice, but anyone who's running a windows xp based system that upgrades from 256 to 512 Mb of ram will see a substantial performance increase and less hard drive thrashing. You'll be glad you made the investment when you see the speed benefits. All of this is of course assuming your machine is free of nasty malware of any kind Wink James.

Collapse -
RAM STARVING
by yosi7 / April 29, 2005 12:38 AM PDT
In reply to: A few notes

You are absolutely right. I upgraded my desktop RAM from 256 to 512 and now it's flying. On the other hand my notebook has already 512 and shows HDD overactivity and performance deterioration. I have a 700MB swap file recommended by the system and now I was advised by a fellow member of this forum to increase it to 4GB to solve the problem of HDD overactivity which is caused by file swapping. I Will try and inform. Thanks. Joe.

P.S. By the way on my desktop I also installed a new Graphic card that let me enjoy the benefit of two monitors that Window XP grants and it's much better and more useful than only one big and expensive monitor.

Collapse -
why is my computter so busy?
by newpvp / April 29, 2005 12:40 AM PDT

unable to locate any that reads "start up type". any suggestions?

Collapse -
Right-click 'Indexing Service' in the list
by Felitec / April 29, 2005 1:01 AM PDT

The startup type can be changed on the 'General' page of the 'Indexing Service Properties' dialog.

Right-click 'Indexing Service' in the Services list and select 'Properties'.

Collapse -
Slightly Misleading
by m_and_m_kid / April 29, 2005 1:07 AM PDT

On most all Windows Installs, you have to expressivly enable the Indexing Service. (Either that, or the install disks I have are just wierd!) More likely its the Disk Defragger, that does run by default, unless its on a laptop running on battery, then the settings are dependent on the OEM install settings...

So, am I simply incorrect by saying that the indexing service is disabled, and probably not what the offending module is, but the defragger?

Collapse -
I never had the option
by Artistichaos / April 29, 2005 2:04 AM PDT
In reply to: Slightly Misleading

I have reinstalled windows XP many times, and never did I get the the option of turning on or off the indexing service. I run XP Pro, so you'd think if there was an option the Pro edition would have it.

but, I turned mine off thru the services.msc

Collapse -
Phone Security
by DavidJ / May 8, 2005 4:31 PM PDT
In reply to: I never had the option

Various phones have different options re security.. i.e. incoming calls only, incoming calls (number in phonebook only), outgoing to only phonebook, outgoing to selected numbers only... i.e. hotkeys 1-9..

911 send is always available.

then there is the total lockdown security.. miss it 3 times and your sim is blown, sorta like bank cards (too many missed pins in a row and the card is seized) (fyi most BANK interac machines take your picture for later fraud investigations) while the mom and pop store interac machines usually don't.. but some machines if you don't grab your money in a reasonable time then take back the money and drop it into a seperate bin (real pain if your near your daily limit or avaiable cash in bank)

Collapse -
Disabling it
by m_and_m_kid / May 8, 2005 7:58 PM PDT
In reply to: I never had the option

its under Add-Remove Programs/Add-Remove Windows Components... its not enabled by default...

Collapse -
Cannot find Indexed Services
by djinnepopu / April 29, 2005 4:13 AM PDT

Hum...Hum...
I tried it and after typing the required run command, I only see one "Services Local" which has 2 tabs: "External" and "Standard"
How come is it that I do not see Indexed Services ????
Thanks

Collapse -
Finding the "Indexing Service" after running "services.msc"
by yosi7 / April 29, 2005 6:52 PM PDT

If you can only see the Extended and the Standard tabs and not the list of files probably it was deleted or not created. You have to select "refresh" from the "Action" menu and a list of the services will be created. There you will find the Indexing Service. But I have to inform you that not always it resolves the problem of HDD overactivity because the problem depends on many other factors mentioned in all the responses published about the problem. In my case the problem was solved by increasing the size of the Swap File that gave space to a lot of running programs and processes and diminished the constant read/write process in the HDD. Joe.

Collapse -
???
by jayso / May 8, 2005 7:21 AM PDT

I thought the swap file was read/write to the hard drive???

Collapse -
Startup Services Configuration
by Cripshay / April 29, 2005 5:33 AM PDT
Collapse -
"Safe" Configuration
by Cripshay / April 29, 2005 5:35 AM PDT

By the way, if you click on the link I gave above, I have everything running on the "SAFE" configuration Black Viper has listed, and my computer is running fine. This is the configuration I recommend.

Collapse -
INDEXER
by MESMD / April 29, 2005 5:48 AM PDT

HI MATTI,
I removed or deleted the indexer when I cleaned my fat32 xp system and it deleted most of the files. I had to reinstall win xp!!!

Collapse -
large number of files
by myyoj2000 / April 29, 2005 6:00 AM PDT

what do you consider a "large number" of files?

Collapse -
CPU usage
by yobosaeyo / April 29, 2005 7:10 AM PDT

Or you could have a trojan that has slipped in past your scanners. I recently ran across the same thing and none of my programs found anything! I used I.E. and a a couple of the online virus scanners and trojan scanners and sure enough there in my windows system folder was this sneaky little trojan. As soon as I remmoved it all of my cpu usage was gone! Now I am back to my normal 2% while the system is not loaded up with programs.

Collapse -
sneaky little trojan
by yosi7 / April 29, 2005 8:05 PM PDT
In reply to: CPU usage

What kind of scanners did you run to trace the "sneaky little trojan". I runned a lot of scanners and didn't succeed to neutralize completely the HDD overactivity and worse of all the over CPU usage that affects performance. Thanks. Joe.

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Big stars on small screens

Smosh tells CNET what it took to make it big online

Internet sensations Ian Hecox and Anthony Padilla discuss how YouTube has changed and why among all their goals, "real TV" isn't an ambition.