Computer Help forum

General discussion

4/15/05 Transferring files and sharing a printer between PCs

by Lee Koo (ADMIN) CNET staff/forum admin / April 14, 2005 4:10 AM PDT

Happy Friday!

Thanks to everyone who participated in this week's question. And a huge thanks to the 3 musketeers: Nigel, James, and Jamie, who wrote out some really extensive instructions!

While many advice from our members do somewhat overlap, please don't undermine another person's advice because they are great suggestions. So read through them all. And as always, if you have more questions to ask about the topic of setting up your network to transfer files and sharing a printer between computers, or have any additional helpful tips to offer, please by all means participate and add to this thread.

Thanks everyone and have a great weekend!
-Lee Koo
CNET Community


Question:

I currently have a PC running Windows XP Home and a laptop
running Windows XP Professional. I have a wireless network so
that I can access the Internet on my laptop. My desktop PC is
currently hooked up to the printer. What I would like to do
is two things: print from my laptop and transfer files to and
from both computers. How can I do this? Thank you in advance!

Submitted by: Kitty

(Answers by members are found in the thread below.)

Post a reply
Discussion is locked
You are posting a reply to: 4/15/05 Transferring files and sharing a printer between PCs
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: 4/15/05 Transferring files and sharing a printer between PCs
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Nigel B.'s winning answer
by Lee Koo (ADMIN) CNET staff/forum admin / April 14, 2005 4:40 AM PDT
Answer:

Sharing Printers and Files over a private network.

File and printer sharing is fairly simple and since you have a wireless network set up, you are already half-way there. The good news is, everything you need is built into Windows - all you have to do is set it up.

However there are one or two pitfalls:
- File and printer sharing needs to be turned on
- Firewall software such as Norton Internet security or ZoneAlarm need to be told not to block the connection. Don't be tempted to just turn these off as you will leave yourself open to all kinds of internet nasties.
- You need to be logged in as an administrator to be able to do some of the things described below.

Sharing, whether we're talking about printers or files, involves creation of a share on one computer, and connection to that share on another. The principle is the same for both files and printers.
When you create a share, you give it a name which is used along with the computer's name to access it. The computer likes to see the name as follows
\\computer\share - where "computer" is the name of your computer and "share" is the name of the item being shared. We'll use this below.

Firstly to share your printer:

1. On the computer to which the printer is attached, click start->settings->Printers and Faxes
2. Right-click the printer you want to share, and choose "Sharing"
3. At this point you may either see some sharing options, or a message stating that sharing needs to be turned on.
- If sharing needs to be turned on, follow the instructions headed "Turning on Sharing" below, and then come back to this point.
4. You will now see an option to share the printer. Click "Share this printer" and enter a short name in the box. Hint- I usually put in the printer's brand name or model number. Click "OK"
(ignore any message about ms-dos workstations - just click yes)
Thats it, the printer is now shared.

To connect to your printer from the other computer:

1. On your other pc, click start->settings->Printers and Faxes
2. Click File->Add printer
3. At the Welcome page, click ?Next?
4. Choose "A network printer" rather than local
5. Now click "Connect to this printer" and in the box, enter the location of the printer in the form \\computer\share
At this point there may be a long pause followed by an error indicating that the printer cannot be found. If this happens, then something is blocking the connection. Go to the "Unblocking" section below and then return to this point.
6. The computer will ask you whether this should be your default printer. If this is your only printer, the answer should be yes.
7. Click finish to exit the wizard
You should now be able to print.

Secondly to share out your files:

1. Open Windows Explorer and choose or create a folder to share
2. Right-click the folder and choose sharing
3 Click "share this folder on the network" and enter the name you wish it to be known by. - Hint- use the same name as the folder.
4. Also click "allow network users to change my files" if you want to get full control from your other pc. Click "OK"
5. The folder is now shared

To connect to your shared folder from the other computer:

1. On your other pc, open windows explorer
2. Type in the share name in the form \\computer\share - you should now see the files
3. You may if you wish make the shared folder into a drive letter such as E:
- In windows explorer click tools, map network drive
- Select the drive letter you want to use and type in the share name in the form \\computer\share
- Click "Reconnect at logon" and click "Finish"
You should now see a new drive in windows explorer.

To share more folders and printers, just repeat the steps above. You won't have to turn on sharing or configure firewalls a second time.

-------------------------------

Turning on Sharing

Start the network setup wizard if it isn't already running (start->control panel->network setup wizard)
- there are a number of boxes to work through here
a. "Welcome to the Network Setup Wizard" - just click next
b. "Before you continue" - just click next
c. "The wizard found disconnected network hardware" - if you see this, just click next
d. "Select a connection method" - the first option is the one you should choose if you are using a router or access point to share your internet. The second option is only for computers which get their internet via another computer.
e. Depending on the option you chose in the previous step, you may now be asked to indicate which of your network connections provide internet and which connects you to your private network. In this case the wireless network provides the internet and your local network, so choose wireless for the internet and don't choose anything for the private network.
f. Now you need to type a description for your computer; this can be anything you like. You must also supply a short name which will be used to identify the computer on the network - Hint: keep this short.
g. Finally you have to "name your workgroup". This needs to be the same on both of your computers so you can safely leave it at the default which is usually MSHOME
h. The last question asks whether you want to turn sharing on or off; obviously you want to turn it on
i. A confirmation box now shows you what the wizard is about to set up
j. You now wait while the wizard runs
k. Choose "just finish the wizard" on the next box.
l. Click ?Finish?

Sharing is now enabled.

-------------------------------

Unblocking local network connections

You may be running firewall software such as Norton Internet security. If you don't have any third party firewall software installed, then you are probably running the Windows XP firewall.
Either way, this software will block the connection unless it is told which connections are safe to let through. This is the case for BOTH of your computers so you will have to fix the problem on both!
What we?re going to do here is allow anything sent directly between your computers to pass unhindered, while still protecting you from the outside world.
Now, if you are running a third party firewall, check the Windows XP firewall because it should be turned off.
If you are not running a third party firewall, check that the XP one is turned on.
Click on Start->Settings->Control panel and click "Windows Firewall".
On the "General" tab you can either turn the firewall on or off as required.
If you leave the firewall on, click the "Exceptions" tab and then make sure that File and Printer sharing is ticked. Click OK.

You can stop at this point if you have no other firewall software. Otherwise read the next section. I?m afraid I can?t explain how to set up every firewall on the market ? I have used Norton as an example here.

A simple way to allow sharing in third party firewall software is by IP address. These addresses are generated by your wireless access point and you should be able to find out what "range" of addresses are relevant to your network by checking your access point configuration.
If you don?t know the range, you could take a guess as follows:
Start->Programs->Accessories->Command prompt
Type ipconfig
Under "ip address" you will see an address which looks something like 192.168.1.100
Your address range in this case would be 192.168.1.0 to 192.168.1.254 - you must keep the first three numbers as shown on your screen and substitute the last number with 0 and 254 to get your range.

So by now you should have a range of addresses which you want to allow access to.
Firewall software differs but there should be a box in the configuration which allows you to specify a range. In Norton Internet Security 2004 for example, click "Personal Firewall", then "Configure", then "Networking". Then hit ?Add?, select ?Using a range? and type in the two addresses which describe your range. Click OK twice and then close the main window.

Now if you?ve just finished doing this on your first computer, go and do it again on the other. The address range will be the same.

Hopefully this will have unblocked your network and you can now get sharing.

Submitted by: Nigel B. of Liverpool, UK
Collapse -
File/Print Sharing
by kjohn0258 / April 14, 2005 7:29 PM PDT

I would like to do the exact same thing. The only difference is, that I am using Win 2k Professional.

I have all the recommended service pack updates, but I've tried this in the past and ran into difficulties.
Are the steps the SAME for Win 2k Pro as they are for Win XP?

Please advise

Collapse -
Win XP Pro, 10/100Fast Ethernet switch - non wireless
by SpcL FX / April 14, 2005 11:17 PM PDT
In reply to: File/Print Sharing

Wow, sorry I missed this one. It couldn't be more timely. Are the steps the same for me to share a printer off the above device? My other comps run Me and XPhome. Is this the right device I need or do I need another one? Sorry for coming in late, hope I haven't missed the boat (or should I be on antoher one ..grin..) Thanks in advance guys.
September

Collapse -
i need help setting up my print and file sharing
by djbiglips95630 / April 15, 2005 12:35 AM PDT

at step 5 now click connect to this printer and in the box enter the location of the printer in the form \\ computer \share

Collapse -
Sharing Printers and Files over a private network.
by Stephen.feber / April 14, 2005 9:37 PM PDT

There is a much simpler way - buy Apple. This is 5 times easier in OSX.

Collapse -
How can i do that in Mac OS X
by santiagogiraldo / April 15, 2005 7:01 AM PDT

As any mac user, i know that everything is easier in Mac. But can you give that simple step by step?

Collapse -
How can I do that in Mac OSX?
by squirri / April 18, 2005 4:49 AM PDT

I have had this problem - got an HP Deskjet hooked up to my G5-Imac via USB plus some other machines(Macs and PC's) round the house running OS8/&9. Everything shares the same broadband Internet connection - our home network is wired rather than wireless, but the principals are the same.

First off - the help in Mac OSX sucks! You have to do most of the work on the Windows side(and the help there is not much better - hence this thread!)).

1)Put the OSX machine into the same workgroup the PC's are in(usually MSHOME).(The OSX default workgroup is called WORKGROUP). The easiest way to do this is just to rename the OSX workgroup
2)In the printers and faxes pane turn on sharing for the printer you want to share. I had problems until I made the HP the default printer(you can always change this in the application when you want to print elsewhere).
3) Job done - now swap to the windows machine and just follow the steps the others have given.
4)Don't forget to configure your firewall(I'm using XP Pro/SP2) to allow the printer ports 613&515(can'r remember - you might have to add one of these to the OSX firewall exceptions too). Do this first, otherwise you will get 'Access denied' when you try to use the printer.

This works for me in Panther, but trawling macfixit.com shows that others have used different ways to do this.

Also, if you want to share files, the fact that the OSX box is now in the same workgroup means that the instructions given by James et all work fine(just remember that the first time it connects to either a file or printer you'll need to give your SHORT OSX username, not the long one(e.g. Fred Bloggs) that you usually use to login)

Happy sharing

Collapse -
Stupid reply
by bucca / April 17, 2005 8:39 AM PDT

Mr Feber's fatuous reply is of no help to the original writer and is equally useless to every other user not "blessed" with Apple ownership.

Collapse -
An Additional Wrinkle
by CephJedi / April 15, 2005 12:01 AM PDT

Hi!

I was hoping this question would solve a problem I've had on my home network, but it didn't touch on it.

My read on the original question was that a user has a regular PC attached to a wireless router by good ol' Cat 5 cabling, and the Laptop is on the *wireless* connection and they were having trouble.

This is the situation I have- three PCs on wired connections, two laptops on wireless. I have fussed with all the computers relentlessly and have never been able to share files from wireless to wired. Workgroups are the same, firewall's been eliminated, all the sharing steps have been followed, but to no avail. It almost seems like the router considers it to be two separate networks!

I thought a possible problem was XP pro on the desktops, and XP home on the portables, but that doesn't seem to be it either.

Has anyone else seen this problem or, better yet, managed to fix it?

Thanks in Advance! CephJedi

Collapse -
Printing
by willytel / April 15, 2005 2:18 AM PDT
In reply to: An Additional Wrinkle

CephJedi,

I have a similar set up to your discription. What I have done was connect my printer to a print server (Linksys PPS1UW) that is connected to the router. This allows me to keep only the printer on all the time without the need for having the computer it was connected to on, also. What this allows is for the printer to be shared on the network and not through a PC. In my case I have 2 desktops connected to the router via cable and a wireless desktop on another floor. All which can share the printer. You need to make sure that when you install your printer that you choose the correct port assignment. It is not your LPT1 port. Hope this may give you a additional option to try.
As for your sharing issue, you can right click on any folder that you want to share with other computers and follow the directions to enable sharing.

Bill.

Collapse -
Re: Wrinkle
by Droid / April 23, 2005 5:55 AM PDT
In reply to: An Additional Wrinkle

Hi CephJedi

My router is a Linksys and I have one computer wired and the other wireless. It's working fine for me but I don't have any explanation for you! Have you tried calling tech support for your router just in case theres something special you need to do with it ?

Nigel

Collapse -
Connecting from a PC to a Printer
by badsocref / April 15, 2005 12:39 AM PDT

This came a day too late for me. I fought for over an hour to get a stupid Win2000 machine connected to a network printer (can't upgrade to XP due to a software incompability). Anyway, I finally succeeded. I'm sure I'll be able to do it quicker next time, but it's crazy that one should have to go through three different 'wizards' to get a printer to be recognized. In this respect, I much prefer Macs.

rr

Collapse -
File Sharing-Nigel
by ipyramus / April 15, 2005 1:10 AM PDT

You are amazingly clear and intellegent. Thank you for helping me. The English are always there when Americans need them.

Collapse -
Re: Clever
by Droid / April 23, 2005 5:56 AM PDT
In reply to: File Sharing-Nigel

Thank you! I'm going to print that and stick it up at work, where everyone can see it Happy

Nigel

Collapse -
File and printer sharing
by raywebs / April 15, 2005 1:32 AM PDT

What a thoro reply to a question I was about to ask. However, I got stopped at "go". I don't remember by Administrator name/pw. How can I work around that problem ?

Collapse -
Contact Admin error when sharing.
by felipe_pulido / April 15, 2005 2:07 AM PDT

When I try to share my files, my Laptop sees the desktop, but when I try to open the desktop it just brings an error... contact network administrator... would it be the case of unblocking the network? I am running Norton on the Desktop, but haven't really messed with the Firewall settings... I will give it a try, but if you can please let me know if it will be part of this error message.

Thank you

J. P.

Collapse -
Permission or password
by rcharaf / April 15, 2005 3:48 AM PDT

I have the same problem, the laptop can see the desktop and viceversa, but when i try to access, it keeps saying i don?t have permission and contact the administrator

Collapse -
Follow Nigels directions about getting network info ,and
by riverupdude / April 16, 2005 1:49 AM PDT
In reply to: Permission or password

Granted, you may have other issues/problems with your systems, but I had the same problem. Try going into your firewall software and add a rule to either open up a range of IPs or do as I've done an entire subnet eg: 192.168.1.0 (that allows hosts from 192.168.1.1 thru .254 to traverse your firewall.

Collapse -
Contact Admin error when sharing
by hyloman / April 15, 2005 9:47 AM PDT

In Windows 2000, there is a "guest" user account. Check to see if it is disabled in the USERS AND PASSWORDS of CONTROL PANEL. Uncheck the DISABLED box of this "guest" account and see what happens.

Collapse -
sharing on the network
by Plucky Filly / April 15, 2005 5:05 AM PDT

I read with interest the script on Nigels reply to sharing printers and files on a private network but being an older person I am unable to take this all in and would have liked to print the message for referring to as I would follow the instructions given but it would seem all I get is a blank page I have tried twice but its not going to allow me to do this. Is there a way I can retain the information the course is interesting but way over my head and I am struggling a little. Thanks Ann (plucky filly)

Collapse -
printing the webpage
by sgtbaj / April 15, 2005 7:48 AM PDT
In reply to: sharing on the network

I usually just right click my mouse over the text you want printed. When the box opens up press "select all". This will make all of the items on the screen turn blue. Then go to your printer icon at the top of the page and left click it with the mouse. You should then see all of the page printed out for you.

Collapse -
easy web text printing
by fastpaw / April 15, 2005 9:36 AM PDT
In reply to: sharing on the network

Hi all i do is hold the left mouse button down and select the text required from the page by moveing the mouse then when i have it all turned blue i right click on it and select copy from the menu i then open word and right click in side the page and then select paste the words are then tranfared into word and i can then pick how it is printed out bold etc hope this helps.
if you want the whole page then you can also just press(ctrl and a) that highlights it all.
then (ctrl c) to copy
then open word click inside the page and select (ctrl v) to paste it all in
the brackets are not needed they just highlight the keys to press
have fun ttfn Paul

Collapse -
Printing
by Droid / April 23, 2005 6:20 AM PDT
In reply to: sharing on the network

Hello Ann

I find that Internet Explorer sometimes doesn't print pages properly too! Something that often works for me is to do a File->Print Preview first, then print from there.
Otherwise, you could try installing a different web browser altogether. Firefox works well for me.

Nigel

Collapse -
Fully functional network!
by Jennifer Wall / April 15, 2005 8:34 AM PDT

Many thanks! Your 'Sharing Printers and Files over a private network' article was just what I have been looking for since last autumn. I had set up my wireless network having done the Cnet wireless networking online course, but fell short of sharing files and printers. Two desktops and two laptops and internet access without wires has been wonderful, but now I feel my network is at last fully functional thanks to your unblocking local network connections instructions in particular. Jennifer

Collapse -
How to setup ZoneAlarm
by Silver Leaf / April 15, 2005 9:41 AM PDT

Nigel, great response to the file/printer sharing question. Any chance you could go the extra mile and share how to setup the ZoneAlarm firewall. I have WS XP Home SP2. Thanks in advance

Collapse -
Network path could not be found
by bigwardo / April 17, 2005 1:08 AM PDT
In reply to: How to setup ZoneAlarm

Hello all..i have a wired network with 3 pc's.The main pc runs on XP, has a linksys router and is set up for printer/file shareing.The other 2 pc's are running windows 2000pro and can access the internet and share with eachother.The problem i'm having is that when i try and access or even see the main pc from any of the other 2 pc's i get the message..Network path could not be found..
I have disabled windows firewall and use zone alarm pro and believe i have it confirured correctly as it added the network as being trusted when i first set it up.All pc's have a unique ip address and are all called MSHOME as the network group.
It really baffles me as it seems my pc,the main one is totally isolated from the rest even though the other 2 can access the internet,share files etc.and see eachother in the network.
Can anyone point me in the right direction to resolve this?
Many thanks,
bigwardo.

Collapse -
Network path could not be found
by ronwcornelius / July 14, 2005 12:54 PM PDT

I am having a similar problem except my network is wireless. I have a Linksys wireless G router connected to an XP PC. From the XP PC, I can't access files on the Windows 2000 laptops and desktops on the network. The Windows 2000 pcs can share files and printers between each other no problem. I recently replaced a Linksys 802.11b router with the G. Under the old 802.11b router everything worked fine. The XP machine was using Windows firewall under both scenarios.

Collapse -
Did u set up host files
by farrelltech / June 12, 2007 2:00 AM PDT

c:\windows\system32\drivers\etc open host or hosts with notepad, sytax should be explained. ex.

127.0.0.1 loopback(or localhost)
192.168.1.100 laptop
192.168.1.101 Basement

if sytax is not provided type in IP followed by atleast one space followed by computer name(not description)

Let me Know how it goes

Collapse -
What about XP firewall?
by MrFletch / April 15, 2005 12:27 PM PDT

Nigel explained only the Norton way of unblocking network connections but what about the built in XP firewall, everyone's supposed to have it on their computer(whether its ON or OFF).

but anyways

I have a laptop and a PC both runing XP. The laptop has XP firewall set as ON. I notice that i can access the PC from my laptop but i cant access the laptop from my PC. I am assuming because the laptop has the firewall enabled. How do i work around this so i can access Both systems from any computer?

Personal knowledge says i need to add the port number in the firewall's settings under the Exceptions tab.
What port number must i use though? and whether TCP/UDP?

Collapse -
XP firewall
by Droid / April 23, 2005 6:14 AM PDT

One of the reasons I used the wizard in my answer is that it will automatically set the correct firewall options for file sharing. So there wasn't any need to explain what to do.
There's a check box in Windows Firewall to allow File & Print sharing through. If you have that ticked, it should be enough. You could always tick the box that gets you a notification whenever the firewall blocks something - it might help you figure out what is doing the blocking.
Nigel

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Big stars on small screens

Smosh tells CNET what it took to make it big online

Internet sensations Ian Hecox and Anthony Padilla discuss how YouTube has changed and why among all their goals, "real TV" isn't an ambition.