Car Tech forum

General discussion

1999 chevy blazer dash cluster/gauges

by rustytim / February 21, 2009 12:25 AM PST

My 99 blazer seems to have dash cluster problems even though i replaced with a new cluster, my gas gauge don't work and my temp gauge doesn't work, the dash lights for all indications do not light up when key is turned once on ignition, also the odometer light doesn't work once the car is started, if i just turn key to the 1st indent on ignition the odometer works and i can see the P R N D 123 but after the car is started i can see them at all. also when car is cut off the radio remains playing as designed to do until door is open, sometimes when i shut off ignition all power stops, BUT the inside dome remains on unless i utilize the override button on the light panel, this is an intermittent problem, it doesn't always show up as far as the light problem the gauge and cluster problem are constant. all other gauges seem to work as advertised with exception of the fuel and temp gauge and the PRND123 light Is this problem coming from the main computer in engine bay or wiring???(which I haven t found any bad wires)

Post a reply
Discussion is locked
You are posting a reply to: 1999 chevy blazer dash cluster/gauges
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: 1999 chevy blazer dash cluster/gauges
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
have you found a soulution?
by Carruthers3 / August 7, 2009 1:23 PM PDT

We are having almost the exact same problem with our 99 s-10 blazer that we just purchased. Both the temp gauge and fuel gauge seemed to work fine for the first week or so that we owned it then the battery light came on but the battery gauge read at the normal 14 and the battery tested fine. then the next day the fuel and temp gauge just quit working...does anyone know what the problem is?

Collapse -
did you figure it out?
by Alexroachblazer / May 7, 2013 11:32 AM PDT

any luck at fixing it?

Collapse -
help! same problem!
by Alexroachblazer / May 7, 2013 7:19 AM PDT

hey rustytim i am having the same problem with my girlfriends blazer. what turned out to be the problem???

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

CNET Holiday Gift Guide

Looking for great gifts under $100?

Trendy tech gifts don't require a hefty price tag. Choose from these CNET-recommended useful and high-quality gadgets.